summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-01-17 16:52:17 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-01-17 16:56:43 +0100
commitea39d69a350024e71fb4db352b051a5f197259f7 (patch)
treeec7bda01a063c65e4b568560be0e5f76217e508f /x11-misc
parentapp-admin/hcloud: remove old (diff)
downloadgentoo-ea39d69a350024e71fb4db352b051a5f197259f7.tar.gz
gentoo-ea39d69a350024e71fb4db352b051a5f197259f7.tar.bz2
gentoo-ea39d69a350024e71fb4db352b051a5f197259f7.zip
x11-misc/sxcs: new package, add 0.7.3
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/sxcs/Manifest1
-rw-r--r--x11-misc/sxcs/metadata.xml15
-rw-r--r--x11-misc/sxcs/sxcs-0.7.3.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/sxcs/Manifest b/x11-misc/sxcs/Manifest
new file mode 100644
index 000000000000..6d12abc7b27b
--- /dev/null
+++ b/x11-misc/sxcs/Manifest
@@ -0,0 +1 @@
+DIST sxcs-0.7.3.tar.gz 22204 BLAKE2B 04bb29188c89622dd2bc348dbc334963a807691ce6fda2f6a6eafedc860be5855d614aeab801dd6cba916dae67a5af92d37317420a04345f1aa8d9203cc44510 SHA512 dbd11ecae74e7a50a346efd0d919952cdd138ebcf75a369888c9f889fcc2752923152b07bcec5f7d4f259672e3af11762d88d9a0b7fe37342f9f5880ecd724ec
diff --git a/x11-misc/sxcs/metadata.xml b/x11-misc/sxcs/metadata.xml
new file mode 100644
index 000000000000..5ed3aa71f526
--- /dev/null
+++ b/x11-misc/sxcs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>nrk@disroot.org</email>
+ <name>NRK</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="codeberg">NRK/sxcs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/sxcs/sxcs-0.7.3.ebuild b/x11-misc/sxcs/sxcs-0.7.3.ebuild
new file mode 100644
index 000000000000..0ffac067fd37
--- /dev/null
+++ b/x11-misc/sxcs/sxcs-0.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Color picker and magnifier for X11"
+HOMEPAGE="https://codeberg.org/NRK/sxcs"
+
+SRC_URI="https://codeberg.org/NRK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcursor
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ $(tc-getCC) -o sxcs sxcs.c ${CFLAGS} ${LDFLAGS} -l X11 -l Xcursor || die "Compilation failed"
+}
+
+src_install() {
+ dobin sxcs
+ doman sxcs.1
+ dodoc README.md
+}