summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-18 09:55:41 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-18 09:59:29 -0700
commit007a6797c2510ee797db4bb8e4219470b418bb21 (patch)
treee53291b7822513795b6eed44d355efa1a6e829c9 /x11-misc
parentapp-vim/*: bump copyright year. (diff)
downloadgentoo-007a6797c2510ee797db4bb8e4219470b418bb21.tar.gz
gentoo-007a6797c2510ee797db4bb8e4219470b418bb21.tar.bz2
gentoo-007a6797c2510ee797db4bb8e4219470b418bb21.zip
x11-misc/compose-tables: Version bump to 1.7.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index e3fb1475398a..8f1e6329f9f4 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1 +1,2 @@
DIST libX11-1.7.0.tar.bz2 2409144 BLAKE2B 1eb6aa8f2fe50ddb2f6d324429b3d9cecfb48833c3f52f22ae8e32846be614c8db63c57d25e2b1c46612b6b333ff61ceab8ac0b605b117bcea1224f918af8e6d SHA512 f661ca90350fd8a94f054b00f12f5122cea068ebff706acfd399462236c189a296a2358d17d16166635101cf56cc19303dd407873a159932d093c9f33556f9fb
+DIST libX11-1.7.1.tar.bz2 2426509 BLAKE2B 18db9146f1d1907bccc4c5a48c8d6707b070b8b76703ece1948f53a0307996ba3e538e429df6ea0d9c32f577f9d019ba8a1ae63ab28f840d2c35ee9aa01b6748 SHA512 a76f0a82fce6f9b50646a7cd7ec5ee046650f225816050226068a7548fa083ef07d146d40faaf44e033c59c17b0fda5ffdee3a127dac3ab56cee02133819aa3d
diff --git a/x11-misc/compose-tables/compose-tables-1.7.1.ebuild b/x11-misc/compose-tables/compose-tables-1.7.1.ebuild
new file mode 100644
index 000000000000..988bb2a0f33a
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+inherit xorg-3
+
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}