summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-03-25 23:18:08 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-26 09:36:21 +0200
commitf463648dc1028d7600ca66cca8afdec7aae3c280 (patch)
treee7529653230c1c9a0e790412db3da093a2c53813 /x11-misc/xpad
parentsys-devel/dev86: add clang patch to 0.16.21-r3 (diff)
downloadgentoo-f463648dc1028d7600ca66cca8afdec7aae3c280.tar.gz
gentoo-f463648dc1028d7600ca66cca8afdec7aae3c280.tar.bz2
gentoo-f463648dc1028d7600ca66cca8afdec7aae3c280.zip
x11-misc/xpad: add xdg_icon_cache_update
Closes: https://bugs.gentoo.org/835924 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/24751 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/xpad')
-rw-r--r--x11-misc/xpad/xpad-5.7.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-misc/xpad/xpad-5.7.0.ebuild b/x11-misc/xpad/xpad-5.7.0.ebuild
index f445ca27ceed..91cad0d91599 100644
--- a/x11-misc/xpad/xpad-5.7.0.ebuild
+++ b/x11-misc/xpad/xpad-5.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools xdg-utils
DESCRIPTION="A sticky note application for GTK"
HOMEPAGE="https://launchpad.net/xpad"
@@ -34,3 +34,11 @@ src_prepare() {
eautoreconf
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}