summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2022-01-25 20:39:27 +0100
committerAmy Liffey <amynka@gentoo.org>2022-01-25 20:39:52 +0100
commit3e331b69210e58ec14c61517019b78dc0af01615 (patch)
treea2b37505e4abbb30f1050151ac6946f039170319 /x11-misc/tint2
parentdev-ml/ocaml-process: fix ocamlopt build (diff)
downloadgentoo-3e331b69210e58ec14c61517019b78dc0af01615.tar.gz
gentoo-3e331b69210e58ec14c61517019b78dc0af01615.tar.bz2
gentoo-3e331b69210e58ec14c61517019b78dc0af01615.zip
x11-misc/tint2: version bump 17.0.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'x11-misc/tint2')
-rw-r--r--x11-misc/tint2/Manifest1
-rw-r--r--x11-misc/tint2/tint2-17.0.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/tint2/Manifest b/x11-misc/tint2/Manifest
index 793379334e43..39e0ea97036b 100644
--- a/x11-misc/tint2/Manifest
+++ b/x11-misc/tint2/Manifest
@@ -1,2 +1,3 @@
DIST tint2-v16.7.tar.gz 551197 BLAKE2B ef1c5b3dea255e12f6dcea80a29f016e32e48f729f4be3e1fd7421c6fbdbbacde70f42f3052547dca8421b8343d4b41fbf2ea52b07aa4471974f9f0cc6eea7a7 SHA512 a9bb0b55536e09f70b1d14a5748635f5c5ec1b7b22517453a963b240ab593aae43c56e5cbc7b79d5f19103f0e13200faceb2d25afd66c3d941580424ae6d9d31
DIST tint2-v17.0.1.tar.gz 553523 BLAKE2B 112186c95561af22d67707a0d4d17462c3d32bd4c97165066a1c491c628359eabba3563b271a46e980dd65abaf42a4b59dc36c42ee3cdb2b6d6cde616e0acfe5 SHA512 cc887d1d9eb8b69135ec6f1e591c38b374605f36fa7609fc580de6a81f33ec98c74af0ba2ab326f1ae25d52b75d2056a48cc2a76d78da1fd27dfdf7818fe429b
+DIST tint2-v17.0.2.tar.gz 553734 BLAKE2B 73cd89757963f1a3c3460a2e8e61891e77eb12b9809590dbbbc00df00d03e82d33d6175c7e3ff4623a3390e35fe1530263915b4574dedfd46d9401fbc90d769f SHA512 9bfdf9ba33183ed60b95f73e58d9c1c22af83e9973a0e07ff2825d66d19c7103364426753a07eaecd4dbca278dfc6e22737bc6ce38d9b577b65f672f146e7aa2
diff --git a/x11-misc/tint2/tint2-17.0.2.ebuild b/x11-misc/tint2/tint2-17.0.2.ebuild
new file mode 100644
index 000000000000..2486a789a670
--- /dev/null
+++ b/x11-misc/tint2/tint2-17.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Lightweight panel/taskbar for Linux"
+HOMEPAGE="https://gitlab.com/o9000/tint2"
+SRC_URI="https://gitlab.com/o9000/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S=${WORKDIR}/${PN}-v${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="battery startup-notification svg tint2conf"
+
+DEPEND="
+ dev-libs/glib:2
+ svg? ( gnome-base/librsvg:2 )
+ >=media-libs/imlib2-1.4.2[X,png]
+ x11-libs/cairo[X]
+ x11-libs/pango
+ tint2conf? ( x11-libs/gtk+:3 )
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXrender
+ startup-notification? ( x11-libs/startup-notification )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -DENABLE_BATTERY="$(usex battery)"
+ -DENABLE_TINT2CONF="$(usex tint2conf)"
+ -DENABLE_SN="$(usex startup-notification)"
+ -DENABLE_RSVG="$(usex svg)"
+ )
+ cmake_src_configure
+}