summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/superswitcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/superswitcher')
-rw-r--r--x11-misc/superswitcher/Manifest1
-rw-r--r--x11-misc/superswitcher/files/superswitcher-0.6-glib-single-include.patch27
-rw-r--r--x11-misc/superswitcher/files/superswitcher-0.6-wnck-workspace.patch62
-rw-r--r--x11-misc/superswitcher/metadata.xml13
-rw-r--r--x11-misc/superswitcher/superswitcher-0.6.ebuild41
5 files changed, 144 insertions, 0 deletions
diff --git a/x11-misc/superswitcher/Manifest b/x11-misc/superswitcher/Manifest
new file mode 100644
index 000000000000..eec605d48332
--- /dev/null
+++ b/x11-misc/superswitcher/Manifest
@@ -0,0 +1 @@
+DIST superswitcher-0.6.tar.gz 183184 SHA256 232b98d1a9443fcf4f969cf4cf00df3908c3ccb55f36059391da68873d514599 SHA512 7385c14537a81f3e78509ff7399e1caf84f46fae22ce844f70f7cd72c8865d3808af77229744443178da691dfbcf61cae908c2eb54ef1564c83473ed9ff6ae0b WHIRLPOOL 984945cca220b5144dbb7808ff3dc980d4e59fadde33beac865d9c1f9c15d03419a8a57d852057af6f7679fc34dbb906176317f16fcf78f8de62949e7f3c2ee6
diff --git a/x11-misc/superswitcher/files/superswitcher-0.6-glib-single-include.patch b/x11-misc/superswitcher/files/superswitcher-0.6-glib-single-include.patch
new file mode 100644
index 000000000000..fe3249982870
--- /dev/null
+++ b/x11-misc/superswitcher/files/superswitcher-0.6-glib-single-include.patch
@@ -0,0 +1,27 @@
+Index: superswitcher-0.6/src/dbus-object.h
+===================================================================
+--- superswitcher-0.6.orig/src/dbus-object.h
++++ superswitcher-0.6/src/dbus-object.h
+@@ -4,7 +4,7 @@
+ #ifndef SUPERSWITCHER_DBUS_OBJECT_H
+ #define SUPERSWITCHER_DBUS_OBJECT_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ #include "forward_declarations.h"
+
+Index: superswitcher-0.6/src/forward_declarations.h
+===================================================================
+--- superswitcher-0.6.orig/src/forward_declarations.h
++++ superswitcher-0.6/src/forward_declarations.h
+@@ -18,8 +18,7 @@ typedef struct _SSXineramaScreen SSXiner
+ #define ABNORMAL_EXIT_CODE_ANOTHER_INSTANCE_IS_RUNNING 1
+ #define ABNORMAL_EXIT_CODE_UNKNOWN_COMMAND_LINE_OPTION 2
+
+-#include <glib/gerror.h>
+-#include <glib/gtypes.h>
++#include <glib.h>
+ gboolean superswitcher_hide_popup (void *, GError **);
+ gboolean superswitcher_show_popup (void *, GError **);
+ gboolean superswitcher_toggle_popup (void *, GError **);
diff --git a/x11-misc/superswitcher/files/superswitcher-0.6-wnck-workspace.patch b/x11-misc/superswitcher/files/superswitcher-0.6-wnck-workspace.patch
new file mode 100644
index 000000000000..90919a57485b
--- /dev/null
+++ b/x11-misc/superswitcher/files/superswitcher-0.6-wnck-workspace.patch
@@ -0,0 +1,62 @@
+It seems like wnck_window_is_skip_pager isn't all we need to check.
+
+--- superswitcher/src/screen.c
++++ superswitcher/src/screen.c
+@@ -505,6 +505,7 @@
+ static SSWindow *
+ add_window_to_screen (SSScreen *screen, WnckWindow *wnck_window)
+ {
++ WnckWorkspace *wnck_workspace;
+ SSWindow *window;
+ SSWorkspace *workspace;
+ int n;
+@@ -513,7 +514,13 @@
+ return NULL;
+ }
+
+- n = wnck_workspace_get_number (wnck_window_get_workspace (wnck_window));
++ wnck_workspace = wnck_window_get_workspace (wnck_window);
++
++ if (wnck_workspace == NULL) {
++ return NULL;
++ }
++
++ n = wnck_workspace_get_number (wnck_workspace);
+ workspace = ss_screen_get_nth_workspace (screen, n);
+
+ window = ss_window_new (workspace, wnck_window);
+--- superswitcher/src/window.c
++++ superswitcher/src/window.c
+@@ -254,6 +254,7 @@
+ static void
+ on_workspace_changed (WnckWindow *wnck_window, gpointer data)
+ {
++ WnckWorkspace *wnck_workspace;
+ SSWindow *window;
+ SSWorkspace *old_workspace;
+ SSWorkspace *new_workspace;
+@@ -261,12 +262,19 @@
+
+ window = (SSWindow *) data;
+ old_workspace = window->workspace;
+- new_workspace_id = wnck_workspace_get_number (wnck_window_get_workspace (wnck_window));
+- new_workspace = ss_screen_get_nth_workspace (old_workspace->screen, new_workspace_id);
+-
+ ss_workspace_remove_window (old_workspace, window);
++
++ wnck_workspace = wnck_window_get_workspace (wnck_window);
++ if (wnck_workspace) {
++ new_workspace_id = wnck_workspace_get_number (wnck_workspace);
++ new_workspace = ss_screen_get_nth_workspace (old_workspace->screen, new_workspace_id);
++
++ ss_workspace_add_window (new_workspace, window);
++ window->workspace = new_workspace;
++ } else {
++ window->workspace = NULL;
++ }
++
+- window->workspace = new_workspace;
+- ss_workspace_add_window (new_workspace, window);
+ window->new_window_index = -1;
+ gtk_widget_queue_draw (gtk_widget_get_toplevel (window->widget));
+ }
diff --git a/x11-misc/superswitcher/metadata.xml b/x11-misc/superswitcher/metadata.xml
new file mode 100644
index 000000000000..39234cc2df9b
--- /dev/null
+++ b/x11-misc/superswitcher/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">SuperSwitcher is a (more feature-ful) replacement for the Alt-Tab window
+switching behavior and Ctrl-Alt-Left/Right/Up/Down workspace switching behavior
+that is currently provided by Metacity.</longdescription>
+ <upstream>
+ <remote-id type="google-code">superswitcher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/superswitcher/superswitcher-0.6.ebuild b/x11-misc/superswitcher/superswitcher-0.6.ebuild
new file mode 100644
index 000000000000..12d72e102ffd
--- /dev/null
+++ b/x11-misc/superswitcher/superswitcher-0.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A more feature-full replacement of the Alt-Tab window switching behavior"
+HOMEPAGE="http://code.google.com/p/superswitcher/"
+SRC_URI="http://superswitcher.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/dbus-glib
+ dev-libs/glib:2
+ >=gnome-base/gconf-2:2
+ x11-libs/gtk+:2
+ >=x11-libs/libwnck-2.10:1
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrender"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+
+src_prepare() {
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ src/Makefile.am || die #338906
+
+ epatch "${FILESDIR}"/${P}-wnck-workspace.patch
+ epatch "${FILESDIR}"/${PN}-0.6-glib-single-include.patch
+ eautoreconf
+}
+
+src_install() {
+ MAKEOPTS=-j1 default
+}