summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/light-locker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/light-locker')
-rw-r--r--x11-misc/light-locker/Manifest1
-rw-r--r--x11-misc/light-locker/light-locker-1.6.0.ebuild53
-rw-r--r--x11-misc/light-locker/metadata.xml17
3 files changed, 71 insertions, 0 deletions
diff --git a/x11-misc/light-locker/Manifest b/x11-misc/light-locker/Manifest
new file mode 100644
index 000000000000..bb793f36af4c
--- /dev/null
+++ b/x11-misc/light-locker/Manifest
@@ -0,0 +1 @@
+DIST light-locker-1.6.0.tar.bz2 522644 SHA256 63e0cbcc7ceb8ad695b4bbe7eb9ba5fee32f47790ccde048748d8a47edd32ad0 SHA512 23e10a2d32eabf2cfcc898dcb0c8f98cc7c4e02a3fa83d1a5bd19c0f11251123e618f469bada2cd1fa4f028396c5fbe5751f9943b1be4448aefc2d64fea1eb18 WHIRLPOOL 3d16015765caa8f166a7b1ce8529077bca8809b5d4b66f4a29a852a8f610286ea957f87bc0f10b119083153b2412a77232214b8a428999d5522833e779338500
diff --git a/x11-misc/light-locker/light-locker-1.6.0.ebuild b/x11-misc/light-locker/light-locker-1.6.0.ebuild
new file mode 100644
index 000000000000..cfaec1eb7a27
--- /dev/null
+++ b/x11-misc/light-locker/light-locker-1.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A simple locker using lightdm"
+HOMEPAGE="https://github.com/the-cavalry/light-locker"
+SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+consolekit +dpms gtk3 +screensaver -systemd +upower"
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2.25.6:2
+ >=sys-apps/dbus-0.30
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/libXxf86vm
+ consolekit? ( sys-auth/consolekit )
+ dpms? ( x11-libs/libXext )
+ !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ screensaver? ( x11-libs/libXScrnSaver )
+ systemd? ( sys-apps/systemd )
+ upower? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="${RDEPEND}
+ x11-misc/lightdm"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with consolekit console-kit)
+ $(use_with dpms dpms-ext)
+ $(use_with !gtk3 gtk2)
+ $(use_with screensaver x)
+ $(use_with screensaver mit-ext)
+ $(use_with systemd)
+ $(use_with upower)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-misc/light-locker/metadata.xml b/x11-misc/light-locker/metadata.xml
new file mode 100644
index 000000000000..b552d0643948
--- /dev/null
+++ b/x11-misc/light-locker/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+ </maintainer>
+ <use>
+ <flag name="consolekit">Keep track of the various users, sessions, and seats present on the system.</flag>
+ <flag name="dpms">Turn on the display on screensaver deactivation.</flag>
+ <flag name="gtk3">Build with GTK+ 3 instead of GTK+ 2.</flag>
+ <flag name="screensaver">Lock the screen on screensaver activation.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">the-cavalry/light-locker</remote-id>
+ </upstream>
+</pkgmetadata>