summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-20 12:55:49 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-20 13:14:48 +0200
commit8bc90e6048153572a9ee3c34da81744085f84e33 (patch)
tree31c923b37f8ce574902d1f61a11273aace93af1e /x11-misc/i3lock
parentapp-xemacs/slider: amd64 stable wrt bug #666312 (diff)
downloadgentoo-8bc90e6048153572a9ee3c34da81744085f84e33.tar.gz
gentoo-8bc90e6048153572a9ee3c34da81744085f84e33.tar.bz2
gentoo-8bc90e6048153572a9ee3c34da81744085f84e33.zip
x11-misc/i3lock: Version 2.11.1
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/i3lock')
-rw-r--r--x11-misc/i3lock/Manifest1
-rw-r--r--x11-misc/i3lock/i3lock-2.11.1.ebuild48
-rw-r--r--x11-misc/i3lock/i3lock-2.11.ebuild2
3 files changed, 49 insertions, 2 deletions
diff --git a/x11-misc/i3lock/Manifest b/x11-misc/i3lock/Manifest
index 8f83a8483856..c83c03780f99 100644
--- a/x11-misc/i3lock/Manifest
+++ b/x11-misc/i3lock/Manifest
@@ -1,2 +1,3 @@
DIST i3lock-2.10.tar.bz2 23171 BLAKE2B 1c1d0f8e3a85dcebe4a9ee181e399a4ff447ececfbdf5f9488df849316e47233118b7436c269a986fed4e907e6162f3758c8bdad2d20ac156e95a8be185a744c SHA512 ea865b202668212b58d0b97d0263171847e1bd0c529e2fd3d26c15ef253861b9a8357ff2efaa6a4f342c4d0d1ab03bc00f95f4d4008760ec8e0767ac29195517
+DIST i3lock-2.11.1.tar.bz2 145434 BLAKE2B 9a2ff0be922162710f9dbbf597f93ad939684641d2264c6ed38dc8a7eeb77c253f61aa1a2e873f03de2c8cc6d661e79ff166e4302c423261a65f66582749c962 SHA512 8b779aa0a560884adc1a508e1f07f712bdf043f72c377c24d5e7e186a6b97f34a5bda7aa67de41f5e15a1a541f4a2c2d28bc284057926a5833d70b67437d073c
DIST i3lock-2.11.tar.bz2 145308 BLAKE2B adacff63670237b945b54ba9709725013f8cfb5bdaf48e6c2cfbc0b035161e44f30393443f9326e3d0635407d1451267d9be8898582a76b3f989660ddcda2440 SHA512 c00741a66fdb5477a4b7e993d173f98fe95f0254fa74c50f83ddf8078a477d26a9fab126fbe31b509df2dbd35ed5ec64b95475621b8babf6f6c0f6db38160c8a
diff --git a/x11-misc/i3lock/i3lock-2.11.1.ebuild b/x11-misc/i3lock/i3lock-2.11.1.ebuild
new file mode 100644
index 000000000000..2df68dac048d
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ virtual/pam
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.11-version.patch
+)
+
+src_prepare() {
+ default
+
+ echo ${PV} > I3LOCK_VERSION
+
+ sed -i -e 's:login:system-auth:' pam/${PN} || die
+
+ eautoreconf
+
+ tc-export CC
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}
diff --git a/x11-misc/i3lock/i3lock-2.11.ebuild b/x11-misc/i3lock/i3lock-2.11.ebuild
index 2df68dac048d..ae7fa086d7be 100644
--- a/x11-misc/i3lock/i3lock-2.11.ebuild
+++ b/x11-misc/i3lock/i3lock-2.11.ebuild
@@ -33,8 +33,6 @@ PATCHES=(
src_prepare() {
default
- echo ${PV} > I3LOCK_VERSION
-
sed -i -e 's:login:system-auth:' pam/${PN} || die
eautoreconf