summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-02-16 17:33:27 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2017-02-16 17:35:35 -0500
commite02a4b7cade78dc402c132fd2ff2d5e8f929edb7 (patch)
tree6b11065522563e7fcf625539940210463ca6e39b /x11-misc/bumblebee
parentnet-dns/unbound: ppc ppc64 stable (bug 597964). (diff)
downloadgentoo-e02a4b7cade78dc402c132fd2ff2d5e8f929edb7.tar.gz
gentoo-e02a4b7cade78dc402c132fd2ff2d5e8f929edb7.tar.bz2
gentoo-e02a4b7cade78dc402c132fd2ff2d5e8f929edb7.zip
x11-misc/bumblebee: sync 9999, minor syntax changes
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/bumblebee')
-rw-r--r--x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild21
-rw-r--r--x11-misc/bumblebee/bumblebee-9999.ebuild8
2 files changed, 10 insertions, 19 deletions
diff --git a/x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild b/x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild
index ef99702e3344..c95fb49785a3 100644
--- a/x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild
+++ b/x11-misc/bumblebee/bumblebee-3.2.1_p20170123.ebuild
@@ -4,11 +4,13 @@
EAPI=6
-inherit autotools readme.gentoo-r1 multilib systemd user
+inherit autotools multilib readme.gentoo-r1 systemd user
if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
EGIT_REPO_URI="git://github.com/Bumblebee-Project/Bumblebee.git"
EGIT_BRANCH="develop"
+ KEYWORDS=""
else
COMMIT="c322bd849aabe6e48b4304b8d13cc4aadc36a30d"
SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
@@ -62,12 +64,9 @@ src_prepare() {
}
src_configure() {
- DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
- You may need to setup your /etc/bumblebee/bumblebee.conf"
-
if use video_cards_nvidia ; then
# Get paths to GL libs for all ABIs
- local nvlib=""
+ local i nvlib=""
for i in $(get_all_libdirs) ; do
nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
done
@@ -80,22 +79,18 @@ src_configure() {
fi
econf \
- --docdir=/usr/share/doc/"${PF}" \
${ECONF_PARAMS}
}
src_install() {
+ default
+
newconfd "${FILESDIR}"/${PN}.confd ${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newenvd "${FILESDIR}"/${PN}.envd 99${PN}
systemd_dounit scripts/systemd/bumblebeed.service
+ local DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+ You may need to setup your /etc/bumblebee/bumblebee.conf"
readme.gentoo_create_doc
-
- default
}
-#
-#pkg_preinst() {
-# use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
-# use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
-#}
diff --git a/x11-misc/bumblebee/bumblebee-9999.ebuild b/x11-misc/bumblebee/bumblebee-9999.ebuild
index 4b832aebac22..c95fb49785a3 100644
--- a/x11-misc/bumblebee/bumblebee-9999.ebuild
+++ b/x11-misc/bumblebee/bumblebee-9999.ebuild
@@ -7,10 +7,10 @@ EAPI=6
inherit autotools multilib readme.gentoo-r1 systemd user
if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
EGIT_REPO_URI="git://github.com/Bumblebee-Project/Bumblebee.git"
EGIT_BRANCH="develop"
KEYWORDS=""
- inherit git-r3
else
COMMIT="c322bd849aabe6e48b4304b8d13cc4aadc36a30d"
SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
@@ -84,6 +84,7 @@ src_configure() {
src_install() {
default
+
newconfd "${FILESDIR}"/${PN}.confd ${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newenvd "${FILESDIR}"/${PN}.envd 99${PN}
@@ -93,8 +94,3 @@ src_install() {
You may need to setup your /etc/bumblebee/bumblebee.conf"
readme.gentoo_create_doc
}
-#
-#pkg_preinst() {
-# use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
-# use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
-#}