summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-23 18:09:54 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:12 +0200
commit00bdc34d243383351a7c6a4f9d5e61e5c561dad8 (patch)
treedb9952e386ae24173e9bdf28d4da548d11a95c58 /x11-misc/alacarte
parentx11-terms/gnome-terminal: Version bump to 3.50.0 (diff)
downloadgentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.tar.gz
gentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.tar.bz2
gentoo-00bdc34d243383351a7c6a4f9d5e61e5c561dad8.zip
x11-misc/alacarte: Version bump to 3.50.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33018 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.50.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index 9e4cf4d460be..9bb4d4d4a670 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.44.3.tar.xz 248692 BLAKE2B bb418aebb595935028b5bec9b08b516d90c6488ef4201b184f51420c5918f986d3dda20c2eb8d7666bb3fa7d4249af59afb00777d93d5715ef54d604943ef952 SHA512 2e10b79527b3343379f7b58efa9ae3a4428d05fee11279ae95e0514712ec97489b1152cabcdf2abcaa3d1e396218e2708b0c47e20e6e55e2d34b848e7e2d9ee2
+DIST alacarte-3.50.0.tar.xz 255404 BLAKE2B c22aeb83f707e4860c9a84311da2bf87e79db8b8859b8c45d5c1d0f6ead896f15b83cd112ac248fbb83b2bf839afbc90d2a24685c767ebaaaa850dfab8b26d35 SHA512 12578c35e8e68c83b46d81edc59444a92dc672a4a91bb4b443bbc0b26d94a3badf5598602dfc62dfbbabce7e3392c081c39055a201d60d4813b23e061014ee17
diff --git a/x11-misc/alacarte/alacarte-3.50.0.ebuild b/x11-misc/alacarte/alacarte-3.50.0.ebuild
new file mode 100644
index 000000000000..e37452553a19
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.50.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}