summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-09-04 19:08:57 -0400
committerMatt Turner <mattst88@gentoo.org>2020-09-08 12:24:58 -0700
commitf512e6cf33c5858b9b5891871c1be566232e784b (patch)
tree01bae61f8fc751d56a8dd4ce82b42c93364355bc /x11-libs
parentdev-python/ctypesgen: Stabilize 1.0.2 arm64, #741226 (diff)
downloadgentoo-f512e6cf33c5858b9b5891871c1be566232e784b.tar.gz
gentoo-f512e6cf33c5858b9b5891871c1be566232e784b.tar.bz2
gentoo-f512e6cf33c5858b9b5891871c1be566232e784b.zip
x11-libs/libSM: EAPI 7
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Michael <fedora.dm0@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17420 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libSM/libSM-1.2.3-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/libSM/libSM-1.2.3-r1.ebuild b/x11-libs/libSM/libSM-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..557451f174c4
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Session Management library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6 +uuid"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ x11-libs/xtrans
+ !elibc_FreeBSD? ( !elibc_SunOS? ( !elibc_Darwin? (
+ uuid? ( >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}] )
+ ) ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}/usr/include/uuid ]] &&
+ [[ -d ${ROOT}/usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}/usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-3_src_configure
+}