summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 04:17:31 +0100
committerSam James <sam@gentoo.org>2023-05-16 04:35:58 +0100
commit1eb927e1848456ddc63f57f6f9d8a09cf5ade668 (patch)
tree4b27803e86f95a3eebcb7eb3fb28dfbc3d0c8316 /x11-drivers/xf86-video-intel
parentsys-apps/hwloc: add Valgrind annotation support (diff)
downloadgentoo-1eb927e1848456ddc63f57f6f9d8a09cf5ade668.tar.gz
gentoo-1eb927e1848456ddc63f57f6f9d8a09cf5ade668.tar.bz2
gentoo-1eb927e1848456ddc63f57f6f9d8a09cf5ade668.zip
x11-drivers/xf86-video-intel: add Valgrind annotation support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-video-intel')
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20230201.ebuild10
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild10
2 files changed, 14 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20230201.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20230201.ebuild
index fef57ffc39e7..0ab021c90388 100644
--- a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20230201.ebuild
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20230201.ebuild
@@ -18,7 +18,7 @@ fi
DESCRIPTION="X.Org driver for Intel cards"
-IUSE="debug +sna tools +udev uxa xvmc"
+IUSE="debug +sna tools +udev uxa valgrind xvmc"
REQUIRED_USE="
|| ( sna uxa )
@@ -50,8 +50,11 @@ RDEPEND="
x11-libs/xcb-util
)
"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ valgrind? ( dev-util/valgrind )
+"
pkg_setup() {
linux-info_pkg_setup
@@ -72,6 +75,7 @@ src_configure() {
$(use_enable tools)
$(use_enable udev)
$(use_enable uxa)
+ $(use_enable valgrind)
$(use_enable xvmc)
)
xorg-3_src_configure
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild
index dd5f84ebed58..d421af04dbac 100644
--- a/x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-9999.ebuild
@@ -18,7 +18,7 @@ fi
DESCRIPTION="X.Org driver for Intel cards"
-IUSE="debug +sna tools +udev uxa xvmc"
+IUSE="debug +sna tools +udev uxa valgrind xvmc"
REQUIRED_USE="
|| ( sna uxa )
@@ -50,8 +50,11 @@ RDEPEND="
x11-libs/xcb-util
)
"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ valgrind? ( dev-util/valgrind )
+"
pkg_setup() {
linux-info_pkg_setup
@@ -72,6 +75,7 @@ src_configure() {
$(use_enable tools)
$(use_enable udev)
$(use_enable uxa)
+ $(use_enable valgrind)
$(use_enable xvmc)
)
xorg-3_src_configure