summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-10-17 22:31:41 -0400
committerMatt Turner <mattst88@gentoo.org>2024-10-17 22:40:13 -0400
commitaa5dd694a65058c8f101bbf88aa2b100d7577ca0 (patch)
tree82d37de5f9e1a8ffa13ffe0444b54d47b6307b9e /x11-drivers/xf86-input-evdev
parentx11-apps/xwud: Version bump to 1.0.7 (diff)
downloadgentoo-aa5dd694a65058c8f101bbf88aa2b100d7577ca0.tar.gz
gentoo-aa5dd694a65058c8f101bbf88aa2b100d7577ca0.tar.bz2
gentoo-aa5dd694a65058c8f101bbf88aa2b100d7577ca0.zip
x11-drivers/xf86-input-evdev: Version bump to 2.11.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-input-evdev')
-rw-r--r--x11-drivers/xf86-input-evdev/Manifest1
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.11.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/Manifest b/x11-drivers/xf86-input-evdev/Manifest
index 85aa3f105f15..7998ca9da01e 100644
--- a/x11-drivers/xf86-input-evdev/Manifest
+++ b/x11-drivers/xf86-input-evdev/Manifest
@@ -1 +1,2 @@
DIST xf86-input-evdev-2.10.6.tar.bz2 408138 BLAKE2B 2b5815e6ee71971e5023392e893d0b8bdba315ff73b34926b9facd95141ff541de052b84a569fe7bbd4b98810afb4d643a3bcaa97fe5a4e23c37e1ce410a9e12 SHA512 560b0a6491d50a46913a5890a35c0367e59f550670993493bd9712d712a9747ddaa6fe5086daabf2fcafa24b0159383787eb273da4a2a60c089bfc0a77ad2ad1
+DIST xf86-input-evdev-2.11.0.tar.xz 351952 BLAKE2B 11e89f0d102f94499d3d848d7047e97274b173535c22f6aefa7715dd0f7b8058bf1cedd65bde7d3eef954ccfb65b62c37ceda49f349490085098e1c39791d561 SHA512 ccd3727d9726565259a81db1c238aba7e414292c3f91e182c048845ac3caf1705c2b16ff1775f3b35ecb3b7088903257085bc90a20265641ccde05b2fc6966df
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.11.0.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.11.0.ebuild
new file mode 100644
index 000000000000..3b92fc784c84
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.18[udev]
+ dev-libs/libevdev
+ sys-libs/mtdev
+ virtual/libudev:="
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-2.6
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~INPUT_EVDEV"
+ fi
+ check_extra_config
+}