summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-07 14:11:47 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-07 14:12:21 -0700
commit3cfff63ff50bc1493bd14a905a1b383f194b62ab (patch)
tree9756180a372a6ca5be4677aa4a9dceb9e1ea8dd2 /x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
parentx11-apps/xclock: Version bump to 1.1.1 (diff)
downloadgentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.tar.gz
gentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.tar.bz2
gentoo-3cfff63ff50bc1493bd14a905a1b383f194b62ab.zip
x11-apps/xdpyinfo: Version bump to 1.3.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild')
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
new file mode 100644
index 000000000000..1be291758419
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+ xorg-3_src_configure
+}