summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-18 21:45:13 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-20 21:03:05 +0200
commit24951530c0eb4ec84533e1e75cd61c1cde2b1929 (patch)
treead5cd2be063e2585d0f027773909c36746627a1a /www-servers/thttpd
parentwww-servers/thttpd: migrate to GLEP 81 (diff)
downloadgentoo-24951530c0eb4ec84533e1e75cd61c1cde2b1929.tar.gz
gentoo-24951530c0eb4ec84533e1e75cd61c1cde2b1929.tar.bz2
gentoo-24951530c0eb4ec84533e1e75cd61c1cde2b1929.zip
www-servers/thttpd: drop old version
Closes: https://bugs.gentoo.org/781548 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'www-servers/thttpd')
-rw-r--r--www-servers/thttpd/thttpd-2.27.1-r1.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/www-servers/thttpd/thttpd-2.27.1-r1.ebuild b/www-servers/thttpd/thttpd-2.27.1-r1.ebuild
deleted file mode 100644
index c7f0958f6ecc..000000000000
--- a/www-servers/thttpd/thttpd-2.27.1-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools flag-o-matic toolchain-funcs user
-
-if [[ ${PV} = 9999* ]]
-then
- EGIT_REPO_URI="https://github.com/blueness/sthttpd.git"
- inherit git-r3
-else
- MY_P="s${P}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/blueness/sthttpd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver"
-HOMEPAGE="https://github.com/blueness/sthttpd http://opensource.dyc.edu/sthttpd"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-
-RDEPEND="virtual/libcrypt:="
-DEPEND="${RDEPEND}"
-
-WEBROOT="/var/www/localhost"
-
-THTTPD_USER=thttpd
-THTTPD_GROUP=thttpd
-THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"
-
-DOCS=( TODO )
-
-pkg_setup() {
- ebegin "Creating thttpd user and group"
- enewgroup ${THTTPD_GROUP}
- enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/thttpd-renamed-htpasswd.patch
- mv "${S}"/extras/{htpasswd.c,th_htpasswd.c} || die
- eapply_user
- eautoreconf -f -i
-}
-
-src_configure() {
- econf WEBDIR=${THTTPD_DOCROOT}
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/thttpd.init.1 thttpd
- newconfd "${FILESDIR}"/thttpd.confd.1 thttpd
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/thttpd.logrotate" thttpd
-
- insinto /etc/thttpd
- doins "${FILESDIR}"/thttpd.conf.sample
-
- #move htdocs to docdir, bug #429632
- docompress -x /usr/share/doc/"${PF}"/htdocs.dist
- mv "${ED}"${WEBROOT}/htdocs \
- "${ED}"/usr/share/doc/"${PF}"/htdocs.dist || die
- mkdir "${ED}"${WEBROOT}/htdocs || die
-
- keepdir ${WEBROOT}/htdocs
-
- chown root:${THTTPD_GROUP} "${ED}/usr/sbin/makeweb" \
- || die "Failed chown makeweb"
- chmod 2751 "${ED}/usr/sbin/makeweb" \
- || die "Failed chmod makeweb"
- chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" \
- || die "Failed chmod printenv"
-}