summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerb Miller Jr <herb@hlmjr.com>2021-05-20 16:59:20 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-07-03 18:42:18 +0300
commitbac424b30a1d45485ee016f418cd6fb0702e470f (patch)
tree4a295ae20fe6d3f050ebf293b4cbf2f374cc0494 /www-servers/lighttpd
parentdev-lang/zig: add missing dies (diff)
downloadgentoo-bac424b30a1d45485ee016f418cd6fb0702e470f.tar.gz
gentoo-bac424b30a1d45485ee016f418cd6fb0702e470f.tar.bz2
gentoo-bac424b30a1d45485ee016f418cd6fb0702e470f.zip
www-servers/lighttpd: Version bump (v1.4.59)
Added Zstandard output compression support and cleaned up ebuild a bit. Closes: https://bugs.gentoo.org/776793 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Herb Miller Jr. <herb@hlmjr.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers/lighttpd')
-rw-r--r--www-servers/lighttpd/Manifest1
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.59.ebuild237
-rw-r--r--www-servers/lighttpd/metadata.xml1
3 files changed, 239 insertions, 0 deletions
diff --git a/www-servers/lighttpd/Manifest b/www-servers/lighttpd/Manifest
index 4451e5293520..545b25d8c85c 100644
--- a/www-servers/lighttpd/Manifest
+++ b/www-servers/lighttpd/Manifest
@@ -1,2 +1,3 @@
DIST lighttpd-1.4.55.tar.xz 765660 BLAKE2B 7b972de86e7d1a51438718e4d5bd49188c107b0f2e656ead597085ae84f3d41cdb662a7774c6655155d390c26f3e4f0b0dc4243c85cb0255a91d8ca57742f402 SHA512 023d5a54079e710a89a59e259c0b5798103ef6fce4544c36110dc4c5281ef429ef99369923d74123fcf8be37afe622d44cd7149078d21971ff26f3f4ee37c439
DIST lighttpd-1.4.58.tar.xz 956828 BLAKE2B b8b0a111db64a8af429dd9922503991e55276808b58143ffce3268bc8b20a39cfec9d8c1e2917b34326ac5502801a6ca3b9bae26874f86b6749c363a09225ca3 SHA512 b7f18223e46bf78f866eb22f44a7702df07424271e085da9f0d03e626198c30e87a3959536d02e3588aa47ba4bc7db7c432307175fb3b25a2984f9cf692c0ca4
+DIST lighttpd-1.4.59.tar.xz 968352 BLAKE2B 8997386be24d9d84fa8012aedd8ac97b3ad4fd19bb756163d3e9b8c6984c740475c6db2810817db9d1a246320bcd81f7ab35847707316454523c614a4485299f SHA512 94d312f6ac65c32057018b749c4865220b43b3e4b7fe9396848aa403ea7fdc2ccbf3f4f91daf281b754cf272a52a8bcdc689502773ea33cae36eead2785daa0f
diff --git a/www-servers/lighttpd/lighttpd-1.4.59.ebuild b/www-servers/lighttpd/lighttpd-1.4.59.ebuild
new file mode 100644
index 000000000000..b3d8e44ff791
--- /dev/null
+++ b/www-servers/lighttpd/lighttpd-1.4.59.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit autotools flag-o-matic lua-single readme.gentoo-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Lightweight high-performance web server"
+HOMEPAGE="https://www.lighttpd.net https://github.com/lighttpd"
+SRC_URI="https://download.lighttpd.net/lighttpd/releases-1.4.x/${P}.tar.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="brotli bzip2 dbi doc gdbm gnutls ipv6 kerberos ldap libev lua maxminddb mbedtls mmap memcached mysql nss pcre php postgres rrdtool sasl selinux ssl sqlite test webdav xattr zlib zstd"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ mysql? ( dbi )
+ postgres? ( dbi )
+ sqlite? ( dbi )
+ webdav? ( sqlite )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+COMMON_DEPEND="
+ acct-group/lighttpd
+ acct-user/lighttpd
+ brotli? ( app-arch/brotli )
+ bzip2? ( app-arch/bzip2 )
+ dbi? (
+ dev-db/libdbi
+ mysql? ( dev-db/libdbi-drivers[mysql] )
+ postgres? ( dev-db/libdbi-drivers[postgres] )
+ sqlite? ( dev-db/libdbi-drivers[sqlite] )
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ gnutls? ( net-libs/gnutls )
+ kerberos? ( virtual/krb5 )
+ ldap? ( >=net-nds/openldap-2.1.26 )
+ libev? ( >=dev-libs/libev-4.01 )
+ lua? ( ${LUA_DEPS} )
+ maxminddb? ( dev-libs/libmaxminddb )
+ mbedtls? ( net-libs/mbedtls )
+ memcached? ( dev-libs/libmemcached )
+ nss? ( dev-libs/nss )
+ pcre? ( >=dev-libs/libpcre-3.1 )
+ php? ( dev-lang/php:*[cgi] )
+ rrdtool? ( net-analyzer/rrdtool )
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( >=dev-libs/openssl-0.9.7:0= )
+ webdav? (
+ dev-libs/libxml2
+ sys-fs/e2fsprogs
+ )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ zstd? ( app-arch/zstd )"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/docutils )
+ test? (
+ virtual/perl-Test-Harness
+ dev-libs/fcgi
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-apache )
+"
+
+# update certain parts of lighttpd.conf based on conditionals
+update_config() {
+ local config="${D}/etc/lighttpd/lighttpd.conf"
+
+ # enable php/mod_fastcgi settings
+ if use php; then sed -i -e 's|#.*\(include.*fastcgi.*$\)|\1|' ${config} || die; fi
+
+ # automatically listen on IPv6 if built with USE=ipv6. Bug #234987
+ if use ipv6; then sed -i -e 's|# server.use-ipv6|server.use-ipv6|' ${config} || die; fi
+}
+
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+
+ if ! use pcre ; then
+ ewarn "It is highly recommended that you build ${PN}"
+ ewarn "with perl regular expressions support via USE=pcre."
+ ewarn "Otherwise you lose support for some core options such"
+ ewarn "as conditionals and modules such as mod_re{write,direct}"
+ ewarn "and mod_ssi."
+ fi
+
+ DOC_CONTENTS="IPv6 migration guide:\n
+ http://redmine.lighttpd.net/projects/lighttpd/wiki/IPv6-Config"
+}
+
+src_prepare() {
+ default
+ if use memcached; then append-ldflags -pthread; fi
+ # dev-python/docutils installs rst2html.py not rst2html
+ sed -i -e 's|\(rst2html\)|\1.py|g' doc/outdated/Makefile.am || \
+ die "sed doc/Makefile.am failed"
+ eautoreconf
+}
+
+src_configure() {
+ # The lua bit requires a bit of explanation. The lighttpd autoconf script
+ # handles the value passed to --with-lua as follows:
+ # - "no" - do nothing
+ # - "yes" - query pkgconfig for VERSIONED lua packages, starting with 5.3
+ # and going down; only if lua5.1 cannot be found plain "lua" is tried
+ # - any other value is passed to pkgconfig as the exact package name to use.
+ # We want a specific implementation to be used even if a newer one is present
+ # in the system so we use the latter mode.
+ econf \
+ CC_FOR_BUILD=$(tc-getBUILD_CC) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --enable-lfs \
+ $(use_enable ipv6) \
+ $(use_enable mmap) \
+ $(use_with brotli) \
+ $(use_with bzip2) \
+ $(use_with dbi) \
+ $(use_with gdbm) \
+ $(use_with gnutls ) \
+ $(use_with kerberos krb5) \
+ $(use_with ldap) \
+ $(use_with libev) \
+ $(use_with lua lua ${ELUA}) \
+ $(use_with maxminddb) \
+ $(use_with mbedtls) \
+ $(use_with memcached) \
+ $(use_with nss) \
+ $(use_with pcre) \
+ $(use_with sasl) \
+ $(use_with ssl openssl) \
+ $(use_with webdav webdav-props) \
+ $(use_with webdav webdav-locks) \
+ $(use_with xattr attr) \
+ $(use_with zlib) \
+ $(use_with zstd)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ einfo "Building HTML documentation"
+ cd doc || die
+ emake html
+ fi
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ default_src_test
+ else
+ ewarn "test skipped, please re-run as root if you wish to test ${PN}"
+ fi
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # init script stuff
+ newinitd "${FILESDIR}"/lighttpd.initd lighttpd
+ newconfd "${FILESDIR}"/lighttpd.confd lighttpd
+
+ # configs
+ insinto /etc/lighttpd
+ doins "${FILESDIR}"/conf/lighttpd.conf
+ doins "${FILESDIR}"/conf/mime-types.conf
+ doins "${FILESDIR}"/conf/mod_cgi.conf
+ doins "${FILESDIR}"/conf/mod_fastcgi.conf
+
+ # update lighttpd.conf directives based on conditionals
+ update_config
+
+ # docs
+ dodoc AUTHORS README NEWS doc/scripts/*.sh
+ newdoc doc/config//lighttpd.conf lighttpd.conf.distrib
+ if use ipv6; then readme.gentoo_create_doc; fi
+
+ if use doc; then dodoc -r doc; fi
+
+ docinto txt
+ dodoc doc/outdated/*.txt
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/lighttpd.logrotate-r1 lighttpd
+
+ keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
+ fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
+ fperms 0750 /var/l{ib,og}/lighttpd
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.conf" "${PN}.conf"
+}
+
+pkg_postinst() {
+ if use ipv6; then readme.gentoo_print_elog; fi
+
+ if [[ -f ${ROOT}/etc/lighttpd.conf ]] ; then
+ elog
+ elog "Gentoo has a customized configuration,"
+ elog "which is now located in /etc/lighttpd. Please migrate your"
+ elog "existing configuration."
+ fi
+
+ if use brotli || use bzip2 || use zlib; then
+ elog
+ elog "Remember to clean your cache directory when using"
+ elog "output compression!"
+ elog "https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModDeflate"
+ fi
+
+ if use mysql; then
+ elog
+ elog "Note that upstream has moved away from using mysql directly"
+ elog "via mod_mysql and is now accessing it through mod_dbi. You"
+ elog "may need to update your configuration"
+ fi
+
+ elog
+ elog "Upstream has deprecated a number of features. They are not missing"
+ elog "but have been migrated to other mechanisms. Please see upstream"
+ elog "changelog for details."
+ elog "https://www.lighttpd.net/2021/2/2/1.4.59/"
+}
diff --git a/www-servers/lighttpd/metadata.xml b/www-servers/lighttpd/metadata.xml
index bdade9103aaa..8477d5d0d91f 100644
--- a/www-servers/lighttpd/metadata.xml
+++ b/www-servers/lighttpd/metadata.xml
@@ -29,5 +29,6 @@
<flag name="rrdtool">Enable rrdtool support via mod_rrdtool</flag>
<flag name="webdav">Enable webdav properties</flag>
<flag name="zlib">Enable output compression via gzip or deflate algorithms</flag>
+ <flag name="zstd">Enable output compression via Zstandard algorithm</flag>
</use>
</pkgmetadata>