summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-07-30 08:41:57 +1000
committerMatt Jolly <kangie@gentoo.org>2024-07-30 08:43:42 +1000
commitea8d28aa98aee00aafd19a81032dc6c9cde530c5 (patch)
tree27d3428ed046fa0233ac20d5e8b8cc89f1b24051 /www-client
parentnet-libs/nodejs: drop 20.12.1 (diff)
downloadgentoo-ea8d28aa98aee00aafd19a81032dc6c9cde530c5.tar.gz
gentoo-ea8d28aa98aee00aafd19a81032dc6c9cde530c5.tar.bz2
gentoo-ea8d28aa98aee00aafd19a81032dc6c9cde530c5.zip
www-client/chromium: fix build with USE="-official" on OpenRC
Closes: https://bugs.gentoo.org/936673 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/chromium-127.0.6533.72.ebuild1
-rw-r--r--www-client/chromium/files/chromium-127-enterprise-companion.patch44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-127.0.6533.72.ebuild b/www-client/chromium/chromium-127.0.6533.72.ebuild
index 0861db4237d8..336aa71c9faf 100644
--- a/www-client/chromium/chromium-127.0.6533.72.ebuild
+++ b/www-client/chromium/chromium-127.0.6533.72.ebuild
@@ -453,6 +453,7 @@ src_prepare() {
"${FILESDIR}/chromium-126-oauth2-client-switches.patch"
"${FILESDIR}/chromium-127-browser-ui-deps.patch"
"${FILESDIR}/chromium-127-bindgen-custom-toolchain.patch"
+ "${FILESDIR}/chromium-127-enterprise-companion.patch"
)
# 127: test deps are broken for ui/lens with system ICU "//third_party/icu:icuuc_public"
diff --git a/www-client/chromium/files/chromium-127-enterprise-companion.patch b/www-client/chromium/files/chromium-127-enterprise-companion.patch
new file mode 100644
index 000000000000..76ce131bba3d
--- /dev/null
+++ b/www-client/chromium/files/chromium-127-enterprise-companion.patch
@@ -0,0 +1,44 @@
+From e7d008ff98df2049cce1c4d941b13b320da336c9 Mon Sep 17 00:00:00 2001
+From: Matt Jolly <Matt.Jolly@footclan.ninja>
+Date: Mon, 29 Jul 2024 23:42:04 +1000
+Subject: [PATCH] no-op enterprise_companion.
+
+For some reason this pulls in updater components which breaks
+builds on OpenRC systems (or any non-systemd system, really).
+
+It doesn't seem essential so we'll just not build it.
+
+Bug: https://bugs.gentoo.org/936673
+Signed-off-by: Matt Jolly <kangie@gentoo.org>
+--- a/chrome/enterprise_companion/BUILD.gn
++++ b/chrome/enterprise_companion/BUILD.gn
+@@ -60,16 +60,16 @@ static_library("client") {
+ deps = [ "//mojo/public/cpp/platform" ]
+ }
+
+-if (!is_official_build) {
+- executable("enterprise_companion") {
+- sources = [ "main.cc" ]
+- deps = [ ":base" ]
+-
+- if (is_win) {
+- configs += [ "//build/config/win:windowed" ]
+- }
+- }
+-}
++#if (!is_official_build) {
++# executable("enterprise_companion") {
++# sources = [ "main.cc" ]
++# deps = [ ":base" ]
++#
++# if (is_win) {
++# configs += [ "//build/config/win:windowed" ]
++# }
++# }
++#}
+
+ group("all") {
+ testonly = true
+--
+2.45.2
+