summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-04 01:20:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-04 01:21:04 +0200
commit22a6eaa521065428a11c453bdf9c3d7e6354abb1 (patch)
treede132afdf0c7b57930ae88988350d744e6a0ce75 /www-client
parentdev-lang/luau: bump to 0.637 (diff)
downloadgentoo-22a6eaa521065428a11c453bdf9c3d7e6354abb1.tar.gz
gentoo-22a6eaa521065428a11c453bdf9c3d7e6354abb1.tar.bz2
gentoo-22a6eaa521065428a11c453bdf9c3d7e6354abb1.zip
www-client/tangram: bump to 3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/tangram/Manifest2
-rw-r--r--www-client/tangram/tangram-3.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/www-client/tangram/Manifest b/www-client/tangram/Manifest
index 7bce789b6181..14749229008f 100644
--- a/www-client/tangram/Manifest
+++ b/www-client/tangram/Manifest
@@ -1 +1,3 @@
DIST tangram-3.0.tar.xz 1379104 BLAKE2B 8a067daf3df328d98af70e66c270ea4e03a5dc6e0e1693d05439feac8cb34bc0816890164fa83f37a1de409a926d8556a192f980586cb71f15bcecb134b89526 SHA512 68914f9f0c08ab272635ae71f796df1e4c66c919a7718e90714978dc16e434681aa8fb475d33bfaaeba31cdb690975457fa9e97f6d866c323e8585149cee7c7b
+DIST tangram-3.1.tar.gz 367083 BLAKE2B 8a3642712937a2bf98fba3bd6752e50f4e2376e4b508045799f91ba7c138b3c398605b45b3743d7769762b1879e120b903a8a52f503c2358f59c256dbc498e0d SHA512 66fe9f0db624f5cca8933dc06c875b716d654fd9bb1f78fea2ba70f70f3b2de5af56fe3eb50594faeee653f2aeba6d89f31a828df68b31988ba5243fceafe5d6
+DIST troll-63392a57392fb8ed944e859269a3751f649f64ec.tar.gz 471050 BLAKE2B f1108e0aee1956f4a5b7c40167b7791917534b8b58061313e9ef6ae1064af9d99fc4ff9776b0cbbf5e694dfd55175db7194f633259d0937ebf2d193973728e02 SHA512 53f093712dd11cf2cc3e0448561b57873d225653bff937efa6a2e264ad3520b601cd623aa0178508e4a81e4f85c187dfc977f7f75bbd15873fce64b48efdcda8
diff --git a/www-client/tangram/tangram-3.1.ebuild b/www-client/tangram/tangram-3.1.ebuild
new file mode 100644
index 000000000000..d2b66e656457
--- /dev/null
+++ b/www-client/tangram/tangram-3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Web browser designed to organize and run Web applications"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Tangram/
+ https://github.com/sonnyp/Tangram/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sonnyp/${PN^}.git"
+else
+ TROLL_COMMIT="63392a57392fb8ed944e859269a3751f649f64ec"
+ SRC_URI="
+ https://github.com/sonnyp/${PN^}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://github.com/sonnyp/troll/archive/${TROLL_COMMIT}.tar.gz
+ -> troll-${TROLL_COMMIT}.tar.gz
+ "
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/gjs-1.76.0
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+ net-libs/webkit-gtk:6
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0-dont-validate-appstream.patch"
+)
+
+DOCS=( README.md TODO.md )
+
+src_prepare() {
+ default
+
+ rm -d "${S}/troll" || die
+ cp -r "${WORKDIR}/troll-${TROLL_COMMIT}" "${S}/troll" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}