summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-01-31 21:00:34 +0100
committerSebastian Pipping <sping@gentoo.org>2021-01-31 21:00:34 +0100
commita25a763b7acf4ba6a02094ce0696baef94e617ee (patch)
treecf4b6837c27a835a1f46def4b10567190c6bd702 /www-client/httrack
parentapp-text/xmlstarlet: Minor QA fixes (diff)
downloadgentoo-a25a763b7acf4ba6a02094ce0696baef94e617ee.tar.gz
gentoo-a25a763b7acf4ba6a02094ce0696baef94e617ee.tar.bz2
gentoo-a25a763b7acf4ba6a02094ce0696baef94e617ee.zip
www-client/httrack: Fix linking with lld for profile 17.1
Closes: https://bugs.gentoo.org/732272 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'www-client/httrack')
-rw-r--r--www-client/httrack/httrack-3.49.2-r2.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r2.ebuild b/www-client/httrack/httrack-3.49.2-r2.ebuild
index 11539e76c331..a6bded23cc64 100644
--- a/www-client/httrack/httrack-3.49.2-r2.ebuild
+++ b/www-client/httrack/httrack-3.49.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit eutils xdg-utils
+inherit autotools multilib eutils xdg-utils
DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
HOMEPAGE="https://www.httrack.com/"
@@ -26,6 +26,20 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.48.13-minizip.patch
)
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable static-libs static)
}