summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-01-20 20:04:39 +0100
committerSam James <sam@gentoo.org>2024-01-21 04:00:34 +0000
commitd19448d9cee152e4354a2a5b184d85fc6957f554 (patch)
tree062b381544e27137c891b1823d2f665ef2b2d565 /www-apps
parentgames-emulation/sameboy-jg: add 0.16.2 (diff)
downloadgentoo-d19448d9cee152e4354a2a5b184d85fc6957f554.tar.gz
gentoo-d19448d9cee152e4354a2a5b184d85fc6957f554.tar.bz2
gentoo-d19448d9cee152e4354a2a5b184d85fc6957f554.zip
www-apps/rutorrent: bump version to 4.2.10
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/34924 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.2.10.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index e64891a77b7e..9048badf117c 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1 +1,2 @@
+DIST rutorrent-4.2.10.tar.gz 2362233 BLAKE2B ea2b1b928e1a7c933ad6e85f5a18810d3f4bf11911da2926e26ba0329b54049dee24a456d0dedd98d106b3b9b460c791eae65a222cbe54ac0c2a49634b6b65a8 SHA512 b57e95591b835fd8d0c0e9acdf9c23dbaf6a37542c46397794da625edd02524af508510e0396308ddfe024d37c92e493134a13aae9dd28c5c642cdbd8d9264a5
DIST rutorrent-4.2.9.tar.gz 2361701 BLAKE2B 8383d49e7f7f8b2781e2d848fbcaf1607056c5f69bb677666fd2ce9c509bbe52d2c3dea04b68b5b2b9ef6801eb4b82ed80ce036298a4945daf8ce282da2d2dfb SHA512 cf7792e68006f60a99c903ca87f5e3f5f6d779874f2fb9d04e37c6283db9c5700e270f3d1c98557f9f971ec9c50cbb16a424f5acd50246212f7a016b2138359e
diff --git a/www-apps/rutorrent/rutorrent-4.2.10.ebuild b/www-apps/rutorrent/rutorrent-4.2.10.ebuild
new file mode 100644
index 000000000000..9c59d3d50153
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.2.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}