summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-11 13:43:46 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-11 13:43:50 +0200
commit80673cb9f000cf5cf03ed971f0b14ae552271272 (patch)
treed89698c9d43a15c59bea5e89c378966225cd18b9 /www-apps/wordpress
parentdev-python/apispec: Switch to pypi sdist (diff)
downloadgentoo-80673cb9f000cf5cf03ed971f0b14ae552271272.tar.gz
gentoo-80673cb9f000cf5cf03ed971f0b14ae552271272.tar.bz2
gentoo-80673cb9f000cf5cf03ed971f0b14ae552271272.zip
www-apps/wordpress: add 6.2_rc1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-6.2_rc1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 20663f2eed3a..6b157027faa2 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
DIST wordpress-6.1.1.tar.gz 22751086 BLAKE2B fbbee51219e4237236c39255deb9e31e566c630cfc66f0c4744fec249ae1d07473a6222b7ec5d84079e616d8d2e790521e57809d357ab56582b4a292dbad82f1 SHA512 b50dd9b5e1628a0285d3f0121d6b4cb3617fb696907ef06c935b40d0a46c9853ce12200e011a58675830602aa6d5b6470a98e8cefeec0f7464145bdc344780bb
+DIST wordpress-6.2-RC1.tar.gz 23020112 BLAKE2B fc831b535614d1c9c725a40685a16e0acfc2c86938daecae3cace752f51184216415038d5a755686e087abb177f50fca881345ff120ed4113edc41c503e3d0de SHA512 a821fe458f99fc451c7150bc08b5f7800242a43a2757a3f9d7eccaddec3ffd5edfb8772b1dcb3d27e092c682f0d73c2712a1b366997881baae0d5e3d034597c5
diff --git a/www-apps/wordpress/wordpress-6.2_rc1.ebuild b/www-apps/wordpress/wordpress-6.2_rc1.ebuild
new file mode 100644
index 000000000000..b6c209d75a8c
--- /dev/null
+++ b/www-apps/wordpress/wordpress-6.2_rc1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2+"
+if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if use !akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if use !examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if use !themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ # allows plugins update if allowed within WP
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}