summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-07-23 17:40:10 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-07-24 09:39:27 +0300
commitcf537edbc90dbe726a4e327ea7468c06a634770f (patch)
tree935e3c1623c0a1fb152582538b59f7515de9a048 /www-apps/hugo
parentnet-misc/ipsvd: update DESCRIPTION (diff)
downloadgentoo-cf537edbc90dbe726a4e327ea7468c06a634770f.tar.gz
gentoo-cf537edbc90dbe726a4e327ea7468c06a634770f.tar.bz2
gentoo-cf537edbc90dbe726a4e327ea7468c06a634770f.zip
www-apps/hugo: add 0.115.4
Signed-off-by: tastytea <gentoo@tastytea.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/hugo')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.115.4.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 113a2f218faa..d70be6e6c098 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -2,3 +2,5 @@ DIST hugo-0.111.3-vendor.tar.xz 5812152 BLAKE2B c3daccdd3e6841df3a45c4fb7c82cf5f
DIST hugo-0.111.3.tar.gz 29191902 BLAKE2B a5c4bf3f53579b7870e5a0bed247feff016d3a06c0683949ecada5083db07ee2108c712b41b1f15edd42f0a77d5649657d3fe76d8704a8a7668911a56b045e3b SHA512 fd9fa9138cf714572d50328abc332edcdaaa3d45440914705d0d2119fd2a062c8df59732d9f5c23f540076e0c5a4104ac1d332f8633d93ab1479f82dd5ecce39
DIST hugo-0.115.2-vendor.tar.xz 6196068 BLAKE2B 0d98ed1f3553c5eb28ceb66751c36d4b0e6bb5838a37166d1c006e4a05a888bfd850250a77c1786293bc34bad2f731052782e42b0d8c1e6cc158c076d46945d4 SHA512 e1eb88cd8fbb01bb86c265e3416bf236cb6b049467218f5ff66e2702f4304eca4ab43edbfbb4d3972d636d4dcf0fd04375fd4ebce2a40b78c1a3de1f27e08049
DIST hugo-0.115.2.tar.gz 28547893 BLAKE2B 18496be5d24be6b0b34ff88806b6621cb361f61641efd67ed11fd413379107aad029b241a7b8730ad016c1eb1469b29feee7af33fbf0b94bb0f2fbe2a209c1bb SHA512 4c35d5d6699de1e675fa0c1dfca0f2436ac3ab7a0c164e7662400fb7b81b16ed23a6961e297f262273c18ef2eaa551b813c7d99a8634d0687e78343b23f275f6
+DIST hugo-0.115.4-vendor.tar.xz 6193628 BLAKE2B 427dc6c66a726ff944b0c782b443a6ae3d3ec1b916127db33ebb6789dc1a8271daf00a3bf47f4fbd4f18fc01648b632c5ad9978237d4a11aac0c30406626c107 SHA512 57d3a421eec9909995453aad032f7775722e6ea72c344a31337c62c0aa7b4b669cf5ba5229e3f6819845eed03712e9972328c13c14f93bee0b97a5392b49779b
+DIST hugo-0.115.4.tar.gz 28554509 BLAKE2B b0a8776580b60af5b4e8d023ed2c046fec1d508eaef568fa06f8591653e0f3a2e1bb65352328de421353c02a5856a6cc713d15b6189184150fabc6a5d3a152b9 SHA512 b5a00aa6601a6df2d1cc9244899b26abdc92e0b57d7431409b483e1bbd892a8026b181f2b9dbe273385b5ca95c3564ca6128afa54d33cbda584946eba20d2eb5
diff --git a/www-apps/hugo/hugo-0.115.4.ebuild b/www-apps/hugo/hugo-0.115.4.ebuild
new file mode 100644
index 000000000000..b8cc129acc16
--- /dev/null
+++ b/www-apps/hugo/hugo-0.115.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +sass test"
+
+BDEPEND="
+ >=dev-lang/go-1.18
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ >=media-libs/libwebp-1.2.3-r1:=
+ sass? ( dev-libs/libsass:= )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.115.2-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev sass "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}