summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-03-31 15:30:13 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-04-07 10:07:11 +0300
commit528689a5ff9fcdb4cb56d796041808569f9098e4 (patch)
treed354e8dcdf26ee9f64ae5578ec55cf358953f685 /www-apps/hugo
parentdev-libs/gmime: Stabilize 3.2.14 ppc64, #928818 (diff)
downloadgentoo-528689a5ff9fcdb4cb56d796041808569f9098e4.tar.gz
gentoo-528689a5ff9fcdb4cb56d796041808569f9098e4.tar.bz2
gentoo-528689a5ff9fcdb4cb56d796041808569f9098e4.zip
www-apps/hugo: add 0.124.1
Signed-off-by: tastytea <gentoo@tastytea.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/hugo')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.124.1.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 42166bc1aec0..7ca9a42c8d18 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -6,3 +6,5 @@ DIST hugo-0.123.0-vendor.tar.xz 6613120 BLAKE2B 4ccf23139eea6cf3d262092234735b9c
DIST hugo-0.123.0.tar.gz 21034964 BLAKE2B 0d1c22d7e8ce71f574cefb1209da82a3de93e6d162ed19cfa950acc159514e5dbc2bd21a6b6116887408a4a257e9f36d6a4a8ad5bb64d5c44db60eccb3238702 SHA512 8835b620d480e86df3a315b101d131b3defde29b21628ba48fe805c1af2625600a5c0fe64ebbab48c8ca56310d5d3aae3c98c27f116a5044ce171a68c072006d
DIST hugo-0.123.7-vendor.tar.xz 6647064 BLAKE2B 4f6932918fa6e2159ad3295332e120d361577647b6b3e63972e475c8863fc43a7b1da2d0ae69b3b7003216f425c4ef1ccabf04fa8367ae5f4bdffa7fd860acc0 SHA512 e3da539a9427be86e1ca792392ac88f02e81d2359e34b0a81478f3006533ca135c367ad8c6f695c3cb37ca7caaa6ef85f3cecba7632cc442db7a3624f7428dca
DIST hugo-0.123.7.tar.gz 21046177 BLAKE2B 518a90dd9aeff0a704fe2f2c7e0f6e0a6eed2489902a24133906dcda9b3fe1d9eaa356b4cb749671cdeb468bb0db3faa0d4f63a9a32d64dc13db7c3a3a172573 SHA512 8fb3331b05c2b1a2218d399cfea5268e2f3622b7122df3bbe68f262d574ae2d946e7b525411abdf82874911fb262f5b88d2ab887585289e7c9f4accd25257552
+DIST hugo-0.124.1-vendor.tar.xz 6740828 BLAKE2B e34cb50eeb22da5f50c8ba7e1318d0f080e6df36f2f1a80e1567d4ccfdd30e4e2ad2153a87c7a18a1d2d6f1e746b5b6c1008d33e41e1900a7e94a42618c5e526 SHA512 2f59a7f2ab199bac5ebf69139b7cc6dd14dc07eab9be39fc39ee5fa41d3332000082407612528d8215a4ebc3a908f28816b19672a28b00bcbad275bea0a9ad35
+DIST hugo-0.124.1.tar.gz 21052060 BLAKE2B 41bd17c3aaf1f137de41957dea049b3d7cdaf101d5bfa128e9412b5ea4eee54a0d30481c059b6982c1b803bbe6634643debf1022079320e653dbb37002f7ea35 SHA512 29f51a08f9e757a716c2f7845efc08b1ca3b0bf8e70fd06491735a123ca7da8e169116fa003c147be08d2d5f9752473e9a569085728ec0a9ed7850bd57ba8f93
diff --git a/www-apps/hugo/hugo-0.124.1.ebuild b/www-apps/hugo/hugo-0.124.1.ebuild
new file mode 100644
index 000000000000..273562b6763b
--- /dev/null
+++ b/www-apps/hugo/hugo-0.124.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.22.1
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.123.0-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}