summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-07-27 09:55:32 -0400
committerCraig Andrews <candrews@gentoo.org>2023-07-27 09:56:01 -0400
commit25976e2d5c073b2a6f2360225de906db4fb9362a (patch)
tree5b1820fc75ac1fe7c05ac871ae552f9ad9ce1d6e /www-apache
parentwww-apps/jackett: drop 0.21.541 (diff)
downloadgentoo-25976e2d5c073b2a6f2360225de906db4fb9362a.tar.gz
gentoo-25976e2d5c073b2a6f2360225de906db4fb9362a.tar.bz2
gentoo-25976e2d5c073b2a6f2360225de906db4fb9362a.zip
www-apache/mod_h2: add 2.0.21
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.21.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index b1674b9cf341..bc5f4c0c5103 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.20.tar.gz 798969 BLAKE2B b5e505af6c3f21ae0ede205582b0c25cbea7b9de4a605434c21f2b34263838355217bc7f5a3396ffaeacd52d4a640d8ed34a8b0a1d81e2d5ea5728df9693e970 SHA512 4622f915a540de7b430094221fd72a5b50509ff0cc07eba947bee716c4d7d35569e8b5e22656f60f8d4f5fc91845ca91c1dd9cfcf40b6948c4fd4ac0fdd68fb3
+DIST mod_h2-2.0.21.tar.gz 671561 BLAKE2B 610e23167466b4c3a42efb08840ec1b24df20d511838764a194b45d315fed610555341e5cb17a0cfdacd8ec3cfb6deec5871a22a5ad108b10e04e05c52432fee SHA512 2c3fdd8116c2154d42b990a2dcc681c764784c59576c43d0456b041fb4d4219f295015c63a37c7583c4cd5bc45709abc5b56d8bef6df5b7ba8178da65d8e90b0
diff --git a/www-apache/mod_h2/mod_h2-2.0.21.ebuild b/www-apache/mod_h2/mod_h2-2.0.21.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.21.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}