summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-12-20 18:17:13 +0000
committerSam James <sam@gentoo.org>2021-12-21 02:04:50 +0000
commit38b60368c54e4cd1e60c9348d205c443a1d09d96 (patch)
treec875a2ef31e3a6a44d59e86769d6162d1cc7a473 /www-apache/modsecurity-crs
parentwww-apps/hugo: Remove old ebuild. (diff)
downloadgentoo-38b60368c54e4cd1e60c9348d205c443a1d09d96.tar.gz
gentoo-38b60368c54e4cd1e60c9348d205c443a1d09d96.tar.bz2
gentoo-38b60368c54e4cd1e60c9348d205c443a1d09d96.zip
www-apache/modsecurity-crs: bump to 3.3.2
Bug: https://bugs.gentoo.org/822003 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache/modsecurity-crs')
-rw-r--r--www-apache/modsecurity-crs/Manifest1
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-3.3.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/www-apache/modsecurity-crs/Manifest b/www-apache/modsecurity-crs/Manifest
index 400f6d47b8f6..1978967f3dfa 100644
--- a/www-apache/modsecurity-crs/Manifest
+++ b/www-apache/modsecurity-crs/Manifest
@@ -1 +1,2 @@
DIST modsecurity-crs-3.3.0.tar.gz 290379 BLAKE2B 557a41e937564698809ecca40d4e76e5c1d3617b62189b7ca230ac7533cba14fdf619bef81c1e40a996dd260d2eb52c27563437dd795c2412bf38715f026f300 SHA512 12043aae12b5e01455e229136411e1fdef3a14318aff191d190b567463b63efb72630a695449b56f1d654ed1cfc0b4eb452a64502c35337d37cce920d5fa4ea4
+DIST modsecurity-crs-3.3.2.tar.gz 290450 BLAKE2B 2935b781af44a206eec881a2c06669db91da98a4d74936299651a77417a2eeaf6d4ab9a1566c08fc4bfb2a60d0b38e71d746d726578ce220b59c9c9cbd800190 SHA512 a5d96fb949da82120a1c4cda4dcf804b06aaae71f25cded5ee998d2c4e766ae2de88e42cd52fc9d63e204415e829af27d80614e58b55509e7bd7ffc20a26cfba
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-3.3.2.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-3.3.2.ebuild
new file mode 100644
index 000000000000..474da42098e7
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-3.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="OWASP ModSecurity Core Rule Set"
+HOMEPAGE="https://coreruleset.org/"
+SRC_URI="https://github.com/coreruleset/coreruleset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=www-apache/mod_security-2.9.1"
+
+S="${WORKDIR}/coreruleset-${PV}"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r rules
+
+ dodoc CHANGES CONTRIBUTORS.md KNOWN_BUGS README.md crs-setup.conf.example
+
+ # I don't think it's worth pulling in apache-module.eclass just for
+ # this path...
+ insinto /etc/apache2/modules.d
+ doins "${FILESDIR}/80_mod_security-crs.conf"
+}
+
+pkg_postinst() {
+ einfo "The CRS configuration file has been installed to:"
+ einfo " ${ROOT}/etc/apache2/modules.d/80_mod_security-crs.conf"
+}