summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2024-02-11 20:29:10 +0800
committerWANG Xuerui <xen0n@gentoo.org>2024-03-09 10:54:50 +0800
commitbbe3e7b43f94d2500332b5a3b0439834da8efb14 (patch)
tree7f7ede11423d33e4c8fbb0bc86668a3ed941b138 /virtual/rust
parentdev-lang/rust: add 1.76.0 (diff)
downloadgentoo-bbe3e7b43f94d2500332b5a3b0439834da8efb14.tar.gz
gentoo-bbe3e7b43f94d2500332b5a3b0439834da8efb14.tar.bz2
gentoo-bbe3e7b43f94d2500332b5a3b0439834da8efb14.zip
virtual/rust: add 1.76.0
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.76.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.76.0.ebuild b/virtual/rust/rust-1.76.0.ebuild
new file mode 100644
index 000000000000..208c9e6ba7a4
--- /dev/null
+++ b/virtual/rust/rust-1.76.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"