summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-25 21:30:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-25 21:31:35 +0300
commitc05dd7abbcac5d7c87d431e7cf173d03484737b2 (patch)
tree31604c51d2265444499a5f4fdb8d6369702e3785 /sys-process
parentapp-crypt/sbctl: add 0.12 (diff)
downloadgentoo-c05dd7abbcac5d7c87d431e7cf173d03484737b2.tar.gz
gentoo-c05dd7abbcac5d7c87d431e7cf173d03484737b2.tar.bz2
gentoo-c05dd7abbcac5d7c87d431e7cf173d03484737b2.zip
sys-process/iotop-c: add 1.25
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.25.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index abfc5bac5c2f..15ca0a5fe15c 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1,2 +1,3 @@
DIST iotop-c-1.23.tar.gz 138772 BLAKE2B 123995c5af48f2d257a4c4b2f342c3cb656d91105e13200baac63c3bd5bdd68a09cf4991363db4d49b211f0ad75285b3f34e66951aa80b2df55f6728c54629dc SHA512 afdc59373e96f23efaf93a661ca31d101732b36e61631844864692599b0e5a1d2355fdda0ec994a8e9ed03bc7f6a37c4dd16336fb750084294d58bfcfc6e7f17
DIST iotop-c-1.24.tar.gz 139533 BLAKE2B 4946876d474750e76ada3f1faa6057b02482f90b917663918669e40ad403c12c90add931c958f868b1b5f4cf1f9c980109795f4322e0db34c84f24f7299b7065 SHA512 4ff78f689ad0734787bfa0bc909a261694b75175301b3f732c170bf8511bab60082a2b363198057ef04b258fe3f4d24e081521f1f4eee6708b595e6a5f80ef2c
+DIST iotop-c-1.25.tar.gz 139627 BLAKE2B a159ae3a4e5be87776d7111e38685e2f83fd907b82a09ec9b4a7d5c778d3a2c5a6e544452c126ff76b0fca2a4038cec1415a654156186dfb2534649a295eb65c SHA512 b696d0478e08373a923475493d67912959d78369f086179590482fb8e6ec349d0c8f5e6118e0aa353d2827b8d83f14bf334cf50cf55f6859bd8d9317543031e0
diff --git a/sys-process/iotop-c/iotop-c-1.25.ebuild b/sys-process/iotop-c/iotop-c-1.25.ebuild
new file mode 100644
index 000000000000..9803d2a23784
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.25.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ !sys-process/iotop
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}