summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-28 07:09:58 +0000
committerSam James <sam@gentoo.org>2025-01-28 07:09:58 +0000
commit8cdc6862a51d9f4681ca789e6308e18714c15721 (patch)
tree8ec0cdbd8f937710d25e38ca659d2d51ea64e814 /sys-process
parentmail-mta/postfix: Stabilize 3.9.1 amd64, #948923 (diff)
downloadgentoo-8cdc6862a51d9f4681ca789e6308e18714c15721.tar.gz
gentoo-8cdc6862a51d9f4681ca789e6308e18714c15721.tar.bz2
gentoo-8cdc6862a51d9f4681ca789e6308e18714c15721.zip
sys-process/numad: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numad/numad-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index fffe3f4192c1..453dd705cae3 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic linux-info systemd toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
@@ -25,13 +25,16 @@ SLOT="0"
CONFIG_CHECK="~NUMA ~CPUSETS"
+PATCHES=(
+ # https://pagure.io/numad/pull-request/3
+ "${FILESDIR}/${PN}-0.5-fix-sparse-node-ids.patch"
+
+ # from debian/ubuntu: https://sources.debian.org/patches/numad
+ "${FILESDIR}/${PN}-0.5-fix-build-for-no-NR-migrate-pages.patch"
+)
+
src_configure() {
tc-export AR CC RANLIB
-
- # FIXME: https://bugs.gentoo.org/890985
- # temp workaround
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
}
src_compile() {