summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2024-10-27 19:58:13 -0400
committerYixun Lan <dlan@gentoo.org>2024-11-10 14:48:48 +0800
commitef2baeb851ef8161ecac97976334551edbca126b (patch)
tree4145c3ce3935b845dcf22e4da79d3343652c9450 /sys-power
parentapp-antivirus/clamav: drop 1.0.5-r1, 1.2.2-r1 (diff)
downloadgentoo-ef2baeb851ef8161ecac97976334551edbca126b.tar.gz
gentoo-ef2baeb851ef8161ecac97976334551edbca126b.tar.bz2
gentoo-ef2baeb851ef8161ecac97976334551edbca126b.zip
sys-power/throttled: add 0.11
Signed-off-by: Violet Purcell <vimproved@inventati.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/throttled/Manifest1
-rw-r--r--sys-power/throttled/throttled-0.11.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-power/throttled/Manifest b/sys-power/throttled/Manifest
index 67d1fc89509a..466cd33cd682 100644
--- a/sys-power/throttled/Manifest
+++ b/sys-power/throttled/Manifest
@@ -1 +1,2 @@
DIST throttled-0.10.0.gh.tar.gz 22191 BLAKE2B c301ee070ff462acd613c90525209eb5237c57e7171bf25133535f9c9a50d226b919065d8f6999f95b45f7f0d4c30e63abb5e04ec768d76b3c82dd19f092a693 SHA512 b89c467295bfc592d7b3ce0c4a41fedf436acf8067f8ef63d8596b92343ed8e04d371d065a9e35fdddba40772f12255c30960c2c46f0cbd5093bfc5e72fb4e18
+DIST throttled-0.11.gh.tar.gz 22195 BLAKE2B d45b8fe04c92dfd2903c1777a3d2bd017cfa4d4f740fa7f7dfc384b4ca902552b386f3e92112dcc57bd6b25644c9bf63a987f9ad4d7c81d3bcfa0a445c1cedfa SHA512 f60ce27d17abd6ddd7db6b77a80ac80e129fba24bbc2d21608d1cc8ed2b0131dac2f53d3fea07ac24f994850146e553c6d4c7fc0dedffee109a1aa6df8684c7a
diff --git a/sys-power/throttled/throttled-0.11.ebuild b/sys-power/throttled/throttled-0.11.ebuild
new file mode 100644
index 000000000000..4b0726246d1e
--- /dev/null
+++ b/sys-power/throttled/throttled-0.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit linux-info python-single-r1 systemd
+
+DESCRIPTION="Daemon to work around throttling issues on some Intel laptops"
+HOMEPAGE="https://github.com/erpalma/throttled"
+SRC_URI="https://github.com/erpalma/throttled/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+
+CONFIG_CHECK="~X86_MSR ~DEVMEM"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ sys-apps/pciutils
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ default
+ python_newscript throttled.py throttled
+ python_domodule mmio.py
+ newinitd "${FILESDIR}/throttled.initd" throttled
+ systemd_dounit "${FILESDIR}/throttled.service"
+ insinto /etc
+ doins etc/throttled.conf
+}