summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-08-09 14:15:13 +0000
committerYixun Lan <dlan@gentoo.org>2023-08-09 14:22:52 +0000
commitda7d884847060ffbedc8e3889a6cd16857fd808e (patch)
tree9877b52725c7df30b317e56247d91a505a21634f /sys-power
parentnet-proxy/haproxy: Bump to 2.8.2 + Cleanup old versions (diff)
downloadgentoo-da7d884847060ffbedc8e3889a6cd16857fd808e.tar.gz
gentoo-da7d884847060ffbedc8e3889a6cd16857fd808e.tar.bz2
gentoo-da7d884847060ffbedc8e3889a6cd16857fd808e.zip
sys-power/thermald: add 2.5.3
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.5.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 28ac2fc50af9..2ed8c3c76fff 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.5.1.tar.gz 160908 BLAKE2B 546d540b53365f9f57059dd74378226ba111abdd0bf9a47a2b81b29726cf2b2d99bfdf166f6b50f30071d28c6fad00d84f48e83f886ec8e50f9f08989b28192a SHA512 76974458b3986cb156ee599e9a96be0082f1e4d85cfe40fd387d69992b0b778186b98abb833a0493db9c070feee8c1147dcf591a7aba039c428e925c66bb0e4f
DIST thermald-2.5.2.tar.gz 162307 BLAKE2B 884fbfb440a0b5e9d1d12bfd7b9173fd79f68b46c499e341f0afdf3d312e10bcd5956b14de7c4c8c0b4db1bc7b675025e3b108bc27cc3cbf236212d0bd642508 SHA512 50ec8c0afb62805d4a86eff91725c468c9035d4524d5d12c187c8b5bbff5a6e723ead7a32bda1a2964fa8a8a8ae437bc7c05d657ea1ac64e4a3d32e6dc0591e2
+DIST thermald-2.5.3.tar.gz 162876 BLAKE2B bfdd297ff703588433d749bb64d0a0cd803b54192e3ee87449433ba89b726836f4050bbb87b7233fe4519686fdbd9bd23408bbeb6a5c31bfdd8b07aa9b723a47 SHA512 2c46e7e02c6ee375f78c8593765f01ff3be82bda3e90c133a9680bfbe7897a3fff78679e1306ee7d76192d7f164ca0ccbfeafd240c56160cdc9c4167827d5ead
diff --git a/sys-power/thermald/thermald-2.5.3.ebuild b/sys-power/thermald/thermald-2.5.3.ebuild
new file mode 100644
index 000000000000..a4a0727b15bf
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+CONFIG_CHECK="~PERF_EVENTS_INTEL_RAPL ~X86_INTEL_PSTATE ~INTEL_POWERCLAMP ~INT340X_THERMAL ~ACPI_THERMAL_REL ~INT3406_THERMAL"
+
+src_prepare() {
+ sed -i -e "/group=/s/power/wheel/g" \
+ data/org.freedesktop.thermald.conf || die
+
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}