summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-08-03 12:08:03 -0400
committerMike Gilbert <floppym@gentoo.org>2024-08-03 12:08:48 -0400
commit7890c9c28a2f7e3531232bf115c409bcbe0d2b12 (patch)
treee3e29828df02fc4ea3266b993273e90cdea2ff97 /sys-libs
parentsys-kernel/installkernel: drop 46 (diff)
downloadgentoo-7890c9c28a2f7e3531232bf115c409bcbe0d2b12.tar.gz
gentoo-7890c9c28a2f7e3531232bf115c409bcbe0d2b12.tar.bz2
gentoo-7890c9c28a2f7e3531232bf115c409bcbe0d2b12.zip
sys-libs/efivar: add 39
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/efivar/Manifest1
-rw-r--r--sys-libs/efivar/efivar-39.ebuild70
-rw-r--r--sys-libs/efivar/metadata.xml2
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-libs/efivar/Manifest b/sys-libs/efivar/Manifest
index 70de2f8e537c..afd23f75ab3c 100644
--- a/sys-libs/efivar/Manifest
+++ b/sys-libs/efivar/Manifest
@@ -1 +1,2 @@
DIST efivar-38.tar.bz2 320221 BLAKE2B 0b96f3d71ddc2246e6a11a5cd32af3d007823c4a283186a428c3f145cd74425a31bd22c4671ad1ab252a3c572991bb1698381cb8bdf51efcbebd62befdc6c070 SHA512 c2f17297c863ece134a9dd758d237fd2df8c8d072f87af1d0bf2bcf9acfc7a53c25597f03fd4fb8cc664b205743d4ffa0ef1b068d0f73c58fa573d40993f3155
+DIST efivar-39.tar.gz 463349 BLAKE2B 73ea4b3293cd708923bcd4332a8c7a5a8bbf539d81300c502a764a2ac205ba7cdf1e30b3432c42a101f56c0b6e31af2907a6a38ada69ace3b0d60e90515094cd SHA512 04493c30efbfc2773abac9a3dd93aa13403c05e29e3bfc72877d2054930811fae99119aadcb1729b6ca85abf5a24db786ea0c27c16d5458ef1b19e74696f5ff7
diff --git a/sys-libs/efivar/efivar-39.ebuild b/sys-libs/efivar/efivar-39.ebuild
new file mode 100644
index 000000000000..be7185d01a41
--- /dev/null
+++ b/sys-libs/efivar/efivar-39.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tools and library to manipulate EFI variables"
+HOMEPAGE="https://github.com/rhboot/efivar"
+SRC_URI="https://github.com/rhboot/efivar/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-text/mandoc
+ test? ( sys-boot/grub:2 )
+"
+RDEPEND="
+ dev-libs/popt
+"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ local PATCHES=(
+ # Rejected upstream, keep this for ia64 support
+ "${FILESDIR}"/efivar-38-ia64-relro.patch
+ )
+ default
+}
+
+src_configure() {
+ unset CROSS_COMPILE
+ export COMPILER=$(tc-getCC)
+ export HOSTCC=$(tc-getBUILD_CC)
+
+ tc-ld-disable-gold
+
+ export libdir="/usr/$(get_libdir)"
+
+ # https://bugs.gentoo.org/562004
+ unset LIBS
+
+ # Avoid -Werror
+ export ERRORS=
+
+ if [[ -n ${GCC_SPECS} ]]; then
+ # The environment overrides the command line.
+ GCC_SPECS+=":${S}/src/include/gcc.specs"
+ fi
+
+ # Used by tests/Makefile
+ export GRUB_PREFIX=grub
+}
+
+src_compile() {
+ # HOST_MARCH: https://bugs.gentoo.org/831334
+ emake HOST_MARCH=
+}
+
+src_test() {
+ # https://bugs.gentoo.org/924370
+ emake -j1 test
+}
diff --git a/sys-libs/efivar/metadata.xml b/sys-libs/efivar/metadata.xml
index 0a27d363fed2..09743f0f8998 100644
--- a/sys-libs/efivar/metadata.xml
+++ b/sys-libs/efivar/metadata.xml
@@ -6,6 +6,6 @@
<name>Mike Gilbert</name>
</maintainer>
<upstream>
- <remote-id type="github">rhinstaller/efivar</remote-id>
+ <remote-id type="github">rhboot/efivar</remote-id>
</upstream>
</pkgmetadata>