summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2023-12-29 17:24:07 -0500
committerSam James <sam@gentoo.org>2024-01-02 06:31:46 +0000
commit3ec6937fc69c5abd9d2fb1d7488115e3372ee96c (patch)
treeaf82c1f68392a2b56c494edfe9db6c4a2a4ddfd8 /sys-libs
parentmedia-video/dvd_info: add 1.16, 9999 (diff)
downloadgentoo-3ec6937fc69c5abd9d2fb1d7488115e3372ee96c.tar.gz
gentoo-3ec6937fc69c5abd9d2fb1d7488115e3372ee96c.tar.bz2
gentoo-3ec6937fc69c5abd9d2fb1d7488115e3372ee96c.zip
sys-libs/libunwind: backport patch to fix build on ppc
See: https://github.com/libunwind/libunwind/issues/520 See: https://github.com/libunwind/libunwind/pull/521 Bug: https://bugs.gentoo.org/913817 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/34554 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/files/libunwind-1.7.2-backport-pr521.patch31
-rw-r--r--sys-libs/libunwind/libunwind-1.7.2.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-libs/libunwind/files/libunwind-1.7.2-backport-pr521.patch b/sys-libs/libunwind/files/libunwind-1.7.2-backport-pr521.patch
new file mode 100644
index 000000000000..addfc0a60a03
--- /dev/null
+++ b/sys-libs/libunwind/files/libunwind-1.7.2-backport-pr521.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/913817
+https://github.com/libunwind/libunwind/issues/520
+https://github.com/libunwind/libunwind/pull/521
+
+From aaf9909c91f1fa875907df8d437bff689e00172e Mon Sep 17 00:00:00 2001
+From: Stephen Webb <swebb@blackberry.com>
+Date: Fri, 26 May 2023 16:22:08 -0400
+Subject: [PATCH] Fix FTBFS on Linux ppc32
+
+Looks like the Linux ucontext structure has changed for PPC at some
+point. This probably needs some kind of version check, or else ancient
+kernels will need to stick with 1.6 or earlier.
+---
+ src/ppc32/ucontext_i.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ppc32/ucontext_i.h b/src/ppc32/ucontext_i.h
+index 64f8ed878..ee93c6979 100644
+--- a/src/ppc32/ucontext_i.h
++++ b/src/ppc32/ucontext_i.h
+@@ -44,8 +44,8 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. */
+ //#define MQ_IDX 36
+ #define LINK_IDX 36
+
+-#define _UC_MCONTEXT_GPR(x) ( (void *)&dmy_ctxt.uc_mcontext.gregs[x] - (void *)&dmy_ctxt) )
+-#define _UC_MCONTEXT_FPR(x) ( ((void *)&dmy_ctxt.uc_mcontext.fpregs[x] - (void *)&dmy_ctxt) )
++#define _UC_MCONTEXT_GPR(x) ( ((void *)&dmy_ctxt.uc_mcontext.uc_regs->gregs[x] - (void *)&dmy_ctxt) )
++#define _UC_MCONTEXT_FPR(x) ( ((void *)&dmy_ctxt.uc_mcontext.uc_regs->fpregs.fpregs[x] - (void *)&dmy_ctxt) )
+
+ /* These are dummy structures used only for obtaining the offsets of the
+ various structure members. */
diff --git a/sys-libs/libunwind/libunwind-1.7.2.ebuild b/sys-libs/libunwind/libunwind-1.7.2.ebuild
index e5cd9a5f96e9..4f420b007d09 100644
--- a/sys-libs/libunwind/libunwind-1.7.2.ebuild
+++ b/sys-libs/libunwind/libunwind-1.7.2.ebuild
@@ -53,6 +53,8 @@ DEPEND="
libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/${PN}-1.7.2-backport-pr521.patch" )
+
MULTILIB_WRAPPED_HEADERS=(
/usr/include/libunwind.h