summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-09 06:22:56 +0000
committerSam James <sam@gentoo.org>2023-03-09 06:22:56 +0000
commita2ac1901e385e027e05a445aa2ab524faadb0f91 (patch)
tree6376e4e883cddace1a5f813c4d03a4c8912d46dd /sys-libs/openipmi
parentapp-containers/sen: enable py3.11 (diff)
downloadgentoo-a2ac1901e385e027e05a445aa2ab524faadb0f91.tar.gz
gentoo-a2ac1901e385e027e05a445aa2ab524faadb0f91.tar.bz2
gentoo-a2ac1901e385e027e05a445aa2ab524faadb0f91.zip
sys-libs/openipmi: drop 2.0.32
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/openipmi')
-rw-r--r--sys-libs/openipmi/Manifest1
-rw-r--r--sys-libs/openipmi/openipmi-2.0.32.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/sys-libs/openipmi/Manifest b/sys-libs/openipmi/Manifest
index 3207390b02a0..ae49ecaf283a 100644
--- a/sys-libs/openipmi/Manifest
+++ b/sys-libs/openipmi/Manifest
@@ -1,2 +1 @@
-DIST OpenIPMI-2.0.32.tar.gz 3140147 BLAKE2B 7f5d3f9e4a5a8388413d1cfb7d1b8bb1a46abce8404b408d4e505bb389e6f871b6f6d67560bcba9a5716dfcf95c5d3c27bbaf4a5fd7b924a629aa4546efde0c1 SHA512 e409f32e6bbf26756338ada386fa394d48d734b4d6ba4beca700ce60bc3af3d0f41e972a328c4e076ae014f4fbd8598d05d3f879f9c6d76198e6ae1a2ba03e95
DIST OpenIPMI-2.0.33.tar.gz 3141439 BLAKE2B 02634ac8e17abf6a95f37e1b6825fe1f493e1990d7a5b0f6e87f7d9527f2a778f9faf0b12566529a3c87ecce893346e5125c51da988b95fbb56145282194ed16 SHA512 615fccd1ffd4af18584c1b0e54667ba2de60b6d42b44e7448f27808114180fa3b31b4834276bdf69c3df1e5210df871fd888deec8186377524838390fe41e641
diff --git a/sys-libs/openipmi/openipmi-2.0.32.ebuild b/sys-libs/openipmi/openipmi-2.0.32.ebuild
deleted file mode 100644
index dee56270e6f3..000000000000
--- a/sys-libs/openipmi/openipmi-2.0.32.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit autotools python-single-r1
-
-MY_PN="OpenIPMI"
-MY_P="${MY_PN}-${PV/_/-}"
-DESCRIPTION="Library interface to IPMI"
-HOMEPAGE="https://sourceforge.net/projects/openipmi/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2.1 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 hppa ~ia64 ppc ppc64 x86"
-IUSE="crypt snmp perl python static-libs tcl"
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/glib:2
- sys-libs/gdbm:=
- sys-libs/ncurses:0=
- sys-libs/readline:0=
- crypt? ( dev-libs/openssl:0= )
- snmp? ( net-analyzer/net-snmp )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl:0= )"
-DEPEND="${RDEPEND}
- >=dev-lang/swig-1.3.21"
-BDEPEND="virtual/pkgconfig"
-
-# Gui is broken!
-# python? ( tcl? ( tk? ( dev-lang/tk dev-tcltk/tix ) ) )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.0.26-tinfo.patch" #501510
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Bug #298250: parallel install fix.
- sed -r -i \
- -e '/^install-data-local:/s,$, install-exec-am,g' \
- cmdlang/Makefile.{am,in} || die
-
- # We touch the .in and .am above because if we use the below, the Perl stuff
- # is very fragile, and often fails to link.
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- # these binaries are for root!
- --bindir="${EPREFIX}"/usr/sbin
- --with-glib
- --with-glibver=2.0
- --with-swig
- --without-tkinter
- $(use_with snmp ucdsnmp yes)
- $(use_with crypt openssl yes)
- $(use_with perl perl yes)
- $(use_with tcl tcl yes)
- $(use_with python python yes)
- )
-
- # GUI is broken
- #use tk && use python && use !tcl && \
- # ewarn "Not building Tk GUI because it needs both Python AND Tcl"
- #if use python && use tcl; then
- # myconf+=( $(use_with tk tkinter) )
- #else
- # myconf+=( --without-tkinter )
- #fi
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.vm
- newdoc cmdlang/README README.cmdlang
-
- use python && python_optimize
-
- find "${ED}" -name "*.la" -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-}