summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/nss-usrfiles
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/nss-usrfiles')
-rw-r--r--sys-libs/nss-usrfiles/Manifest1
-rw-r--r--sys-libs/nss-usrfiles/metadata.xml11
-rw-r--r--sys-libs/nss-usrfiles/nss-usrfiles-2.18.1.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-libs/nss-usrfiles/Manifest b/sys-libs/nss-usrfiles/Manifest
new file mode 100644
index 000000000000..5878aa33529f
--- /dev/null
+++ b/sys-libs/nss-usrfiles/Manifest
@@ -0,0 +1 @@
+DIST nss-altfiles-2.18.1.zip 42369 SHA256 32eb1ecd94c7c789b540e2d047bb90f5a82d3ec02f8b4adbfc48ae55c32aa1d6 SHA512 d9e2c34ce2518a5310578a2b99a59fc1a8142c252c41e5dab0fd0c07e62ccfa2e3c5d2dd29e179514f3b37537bb0576e2bc3c850f459fa251cd57923438981af WHIRLPOOL 7a035ccb0844df32064f7dc6bf027a1cc55ac4421feda2832516445f904ec6616d67e1dcc3387b85553fdeacd566c7fcff970a24888587d16654c444247ae636
diff --git a/sys-libs/nss-usrfiles/metadata.xml b/sys-libs/nss-usrfiles/metadata.xml
new file mode 100644
index 000000000000..64847d14b7cf
--- /dev/null
+++ b/sys-libs/nss-usrfiles/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">coreos/nss-altfiles</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-libs/nss-usrfiles/nss-usrfiles-2.18.1.ebuild b/sys-libs/nss-usrfiles/nss-usrfiles-2.18.1.ebuild
new file mode 100644
index 000000000000..e3bb3d8db160
--- /dev/null
+++ b/sys-libs/nss-usrfiles/nss-usrfiles-2.18.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="nss-altfiles"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="NSS module to read passwd/group files from CoreOS /usr location"
+HOMEPAGE="https://github.com/coreos/${MY_PN}"
+SRC_URI="https://github.com/coreos/${MY_PN}/archive/v${PV}.zip -> ${MY_P}.zip"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ : # Don't bother with the custom configure script.
+}
+
+src_compile() {
+ emake DATADIR=/usr/share/baselayout MODULE_NAME=usrfiles
+}
+
+src_install() {
+ dolib.so libnss_usrfiles.so.2
+}