summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 23:03:09 +0100
committerSam James <sam@gentoo.org>2022-05-31 23:03:09 +0100
commiteb0d76851e8d1c9ffba568763945888bd2fb9c2d (patch)
tree0962c3ac52d2d2b1d0e45361f250f5e86e49464b /sys-libs/newlib
parentdev-python/pytest-httpserver: add missing werkzeug RDEPEND (diff)
downloadgentoo-eb0d76851e8d1c9ffba568763945888bd2fb9c2d.tar.gz
gentoo-eb0d76851e8d1c9ffba568763945888bd2fb9c2d.tar.bz2
gentoo-eb0d76851e8d1c9ffba568763945888bd2fb9c2d.zip
sys-libs/newlib: fix installation on prefix
Closes: https://bugs.gentoo.org/848837 Thanks-to: Christian Ludwig <chrissicool@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/newlib-4.2.0.20211231.ebuild8
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-libs/newlib/newlib-4.2.0.20211231.ebuild b/sys-libs/newlib/newlib-4.2.0.20211231.ebuild
index a6ad7b9c65d1..92cb0eb38425 100644
--- a/sys-libs/newlib/newlib-4.2.0.20211231.ebuild
+++ b/sys-libs/newlib/newlib-4.2.0.20211231.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -143,9 +143,9 @@ src_install() {
done
# Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
- "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
+ mkdir -p "${ED}/usr/${CTARGET}/include/newlib-nano" || die
+ mv "${NEWLIBNANOTMPINSTALL}/${EPREFIX}/usr/${CTARGET}/include/newlib.h" \
+ "${ED}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
fi
# minor hack to keep things clean
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index a6ad7b9c65d1..92cb0eb38425 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -143,9 +143,9 @@ src_install() {
done
# Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
- "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
+ mkdir -p "${ED}/usr/${CTARGET}/include/newlib-nano" || die
+ mv "${NEWLIBNANOTMPINSTALL}/${EPREFIX}/usr/${CTARGET}/include/newlib.h" \
+ "${ED}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
fi
# minor hack to keep things clean