summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-12-19 08:13:16 -0600
committerJory Pratt <anarchy@gentoo.org>2021-12-19 08:13:16 -0600
commit83bdb5a3f5043a447cb0e95adb581eb64417bb48 (patch)
treeb37dd1c67a4d0dd12ae5fe17aa64268d44a587a6 /sys-kernel/zen-sources/zen-sources-5.15.10.ebuild
parentmedia-video/vlc: fix live git repo url (diff)
downloadgentoo-83bdb5a3f5043a447cb0e95adb581eb64417bb48.tar.gz
gentoo-83bdb5a3f5043a447cb0e95adb581eb64417bb48.tar.bz2
gentoo-83bdb5a3f5043a447cb0e95adb581eb64417bb48.zip
sys-kernel/zen-sources: Version bump
Closes: https://bugs.gentoo.org/829546 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'sys-kernel/zen-sources/zen-sources-5.15.10.ebuild')
-rw-r--r--sys-kernel/zen-sources/zen-sources-5.15.10.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/zen-sources/zen-sources-5.15.10.ebuild b/sys-kernel/zen-sources/zen-sources-5.15.10.ebuild
new file mode 100644
index 000000000000..080551ff9414
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-5.15.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+K_SECURITY_UNSUPPORTED="1"
+K_NOSETEXTRAVERSION="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+HOMEPAGE="https://github.com/zen-kernel"
+IUSE=""
+
+DESCRIPTION="The Zen Kernel Live Sources"
+
+ZEN_URI="https://github.com/zen-kernel/zen-kernel/releases/download/v${PV}-zen1/v${PV}-zen1.patch.xz"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${ZEN_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/v${PV}-zen1.patch.xz"
+UNIPATCH_STRICTORDER="yes"
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup() {
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}