summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2021-06-19 12:46:53 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:33:29 +0100
commit099003418573dfc63909ef0874f8bd898d304049 (patch)
treeb1af905f64f3cd3a2e294f176755d34a39908c61 /sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild
parentdev-ml/merlin: remove unneeded emacs dependencies (diff)
downloadgentoo-099003418573dfc63909ef0874f8bd898d304049.tar.gz
gentoo-099003418573dfc63909ef0874f8bd898d304049.tar.bz2
gentoo-099003418573dfc63909ef0874f8bd898d304049.zip
sys-kernel/raspberrypi-image: bump to 5.10.17_p20210527
Closes: https://bugs.gentoo.org/796746 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/21325 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild')
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild
new file mode 100644
index 000000000000..7930d7d6576f
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-5.10.17_p20210527.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+# Temporary safety measure to prevent ending up with a pair of
+# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
+# both of which installed device tree files.
+# Restore to simply "sys-boot/raspberrypi-firmware" when the mentioned version
+# and all older ones are deleted.
+RDEPEND=">sys-boot/raspberrypi-firmware-1.20190709"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm ~arm64"
+fi
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ doins boot/*.img
+
+ doins boot/*.dtb
+ doins -r boot/overlays
+}