summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:22:54 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:43 +0100
commitde685543b4a4739589ffe03e257c5d9ecdca14fd (patch)
tree7c3e53ddb530e8173d3a8024af36093ca988a95d /sys-fs/udisks
parentsys-fs/cryptsetup: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-de685543b4a4739589ffe03e257c5d9ecdca14fd.tar.gz
gentoo-de685543b4a4739589ffe03e257c5d9ecdca14fd.tar.bz2
gentoo-de685543b4a4739589ffe03e257c5d9ecdca14fd.zip
sys-fs/udisks: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/udisks')
-rw-r--r--sys-fs/udisks/udisks-2.9.1-r2.ebuild (renamed from sys-fs/udisks/udisks-2.9.1-r1.ebuild)7
-rw-r--r--sys-fs/udisks/udisks-2.9.2-r2.ebuild (renamed from sys-fs/udisks/udisks-2.9.2-r1.ebuild)7
2 files changed, 10 insertions, 4 deletions
diff --git a/sys-fs/udisks/udisks-2.9.1-r1.ebuild b/sys-fs/udisks/udisks-2.9.1-r2.ebuild
index c6aaf0083376..57047f60efec 100644
--- a/sys-fs/udisks/udisks-2.9.1-r1.ebuild
+++ b/sys-fs/udisks/udisks-2.9.1-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1 linux-info systemd udev xdg-utils
+inherit bash-completion-r1 linux-info systemd tmpfiles udev xdg-utils
DESCRIPTION="Daemon providing interfaces to work with storage devices"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/udisks"
@@ -119,7 +119,10 @@ pkg_preinst() {
}
pkg_postinst() {
- mkdir -p "${EROOT}"/run #415987
+ # TODO: obsolete with tmpfiles_process?
+ #mkdir -p "${EROOT}"/run #415987
+
+ tmpfiles_process udisks2.conf
# See pkg_postinst() of >=sys-apps/baselayout-2.1-r1. Keep in sync?
if ! grep -qs "^tmpfs.*/run " "${EROOT}"/proc/mounts ; then
diff --git a/sys-fs/udisks/udisks-2.9.2-r1.ebuild b/sys-fs/udisks/udisks-2.9.2-r2.ebuild
index 47fbecee3c8c..480609ab96ff 100644
--- a/sys-fs/udisks/udisks-2.9.2-r1.ebuild
+++ b/sys-fs/udisks/udisks-2.9.2-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1 linux-info systemd udev xdg-utils
+inherit bash-completion-r1 linux-info systemd tmpfiles udev xdg-utils
DESCRIPTION="Daemon providing interfaces to work with storage devices"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/udisks"
@@ -122,7 +122,10 @@ pkg_preinst() {
}
pkg_postinst() {
- mkdir -p "${EROOT}"/run #415987
+ # TODO: obsolete with tmpfiles_process?
+ # mkdir -p "${EROOT}"/run #415987
+
+ tmpfiles_process udisks2.conf
# See pkg_postinst() of >=sys-apps/baselayout-2.1-r1. Keep in sync?
if ! grep -qs "^tmpfs.*/run " "${EROOT}"/proc/mounts ; then