summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-fs/snapraid
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/snapraid')
-rw-r--r--sys-fs/snapraid/snapraid-10.0.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-11.0-r1.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-11.2.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-6.2.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-6.3.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-7.0.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-7.1.ebuild3
-rw-r--r--sys-fs/snapraid/snapraid-8.1.ebuild3
8 files changed, 16 insertions, 8 deletions
diff --git a/sys-fs/snapraid/snapraid-10.0.ebuild b/sys-fs/snapraid/snapraid-10.0.ebuild
index 365a2b3e3b77..98f521f8559d 100644
--- a/sys-fs/snapraid/snapraid-10.0.ebuild
+++ b/sys-fs/snapraid/snapraid-10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,5 +11,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-11.0-r1.ebuild b/sys-fs/snapraid/snapraid-11.0-r1.ebuild
index 616bd2007353..57a03c45a1a0 100644
--- a/sys-fs/snapraid/snapraid-11.0-r1.ebuild
+++ b/sys-fs/snapraid/snapraid-11.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-11.2.ebuild b/sys-fs/snapraid/snapraid-11.2.ebuild
index 3784113b2d7a..35f69f087034 100644
--- a/sys-fs/snapraid/snapraid-11.2.ebuild
+++ b/sys-fs/snapraid/snapraid-11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-6.2.ebuild b/sys-fs/snapraid/snapraid-6.2.ebuild
index 7ebac664aa91..97ee8d31b0c1 100644
--- a/sys-fs/snapraid/snapraid-6.2.ebuild
+++ b/sys-fs/snapraid/snapraid-6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-6.3.ebuild b/sys-fs/snapraid/snapraid-6.3.ebuild
index 7ebac664aa91..97ee8d31b0c1 100644
--- a/sys-fs/snapraid/snapraid-6.3.ebuild
+++ b/sys-fs/snapraid/snapraid-6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-7.0.ebuild b/sys-fs/snapraid/snapraid-7.0.ebuild
index 4268c953a344..c8f3100ca6d2 100644
--- a/sys-fs/snapraid/snapraid-7.0.ebuild
+++ b/sys-fs/snapraid/snapraid-7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
diff --git a/sys-fs/snapraid/snapraid-7.1.ebuild b/sys-fs/snapraid/snapraid-7.1.ebuild
index c4608373e996..e33402715818 100644
--- a/sys-fs/snapraid/snapraid-7.1.ebuild
+++ b/sys-fs/snapraid/snapraid-7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
diff --git a/sys-fs/snapraid/snapraid-8.1.ebuild b/sys-fs/snapraid/snapraid-8.1.ebuild
index c4608373e996..e33402715818 100644
--- a/sys-fs/snapraid/snapraid-8.1.ebuild
+++ b/sys-fs/snapraid/snapraid-8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,6 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )