summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-21 22:12:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-21 22:13:15 -0400
commitac44ec31e8a067e0925b5f3d3d647158097cc13a (patch)
tree6ba7aa291b03d50959ffbd0e061531567a2a6eb6 /sys-fs/inotify-tools
parentapp-misc/no-more-secrets: add 1.0.1 (diff)
downloadgentoo-ac44ec31e8a067e0925b5f3d3d647158097cc13a.tar.gz
gentoo-ac44ec31e8a067e0925b5f3d3d647158097cc13a.tar.bz2
gentoo-ac44ec31e8a067e0925b5f3d3d647158097cc13a.zip
sys-fs/inotify-tools: add 4.23.8.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest1
-rw-r--r--sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index f30e8b03f648..2974fbd11a07 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -1 +1,2 @@
DIST inotify-tools-3.22.6.0.tar.gz 92918 BLAKE2B 601d3ac6896e445d297a04498c63df4f81c59699ba2d5b2eee2e8c499332913ce2783d13c9906d577ff0b6d7ef91ca826d48b01674adeb3d3569dfc1fbc0df63 SHA512 cda445add4b9d80b70eff9189ed50d05f4b5593a755159d0354431166c6fe6fdb33f7bf37fd50bc09aad3ed0a6e3763b9c74f65e554400f2596b8d492f1d0a21
+DIST inotify-tools-4.23.8.0.tar.gz 93265 BLAKE2B 9aa6d33a090dd0ea055550c6540e4a7d4f0bcea0640d97c705dacecbddf388423ce217af9ac6df02bebfb0613f160d1860388c6f4e116d7c6cbc3fb42350a312 SHA512 0601f01aaf5be08fc5209710ea8c359b21d2dd6acd4ecfad79d86b287ea51b0b9201339d1bf6c3437e611ba3df760adec9ad7bb4083f13f93649e23d60fb64ed
diff --git a/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild b/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild
new file mode 100644
index 000000000000..451fdbab4d0e
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-4.23.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools/"
+SRC_URI="
+ https://github.com/inotify-tools/inotify-tools/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~riscv ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ sed -i 's/ -Werror//' {,libinotifytools/}src/Makefile.am || die #745069
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}