summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-24 11:41:54 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-24 11:54:03 +0100
commit26c478ad3d9cab8ae6f927f45e632703a84f658a (patch)
treeb87cdc722fd54c06626053e1d6279c264e2c1aee /sys-devel/kgcc64/kgcc64-7.3.0.ebuild
parentnet-libs/http-parser: Maintain this. (diff)
downloadgentoo-26c478ad3d9cab8ae6f927f45e632703a84f658a.tar.gz
gentoo-26c478ad3d9cab8ae6f927f45e632703a84f658a.tar.bz2
gentoo-26c478ad3d9cab8ae6f927f45e632703a84f658a.zip
sys-devel/kgcc64: Version 7.3.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-7.3.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-7.3.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-7.3.0.ebuild b/sys-devel/kgcc64/kgcc64-7.3.0.ebuild
new file mode 100644
index 000000000000..38de4ce987d3
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-7.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+inherit eutils toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~mips"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}