summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 16:16:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:20 +0100
commit18f280c97a9d90141ea69391788ca04f0623b9d5 (patch)
tree10f4d60f0f15a0e1dd5c0b332df58ed3562c9218 /sys-devel/clang-common
parentdev-ml/llvm-ocaml: Add 15.x live ebuild (diff)
downloadgentoo-18f280c97a9d90141ea69391788ca04f0623b9d5.tar.gz
gentoo-18f280c97a9d90141ea69391788ca04f0623b9d5.tar.bz2
gentoo-18f280c97a9d90141ea69391788ca04f0623b9d5.zip
sys-devel/clang-common: Add 15.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.0.9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
new file mode 100644
index 000000000000..71768ae561e5
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}