summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/byfl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/byfl')
-rw-r--r--sys-devel/byfl/Manifest1
-rw-r--r--sys-devel/byfl/byfl-1.2.ebuild44
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild44
-rw-r--r--sys-devel/byfl/metadata.xml14
4 files changed, 103 insertions, 0 deletions
diff --git a/sys-devel/byfl/Manifest b/sys-devel/byfl/Manifest
new file mode 100644
index 000000000000..08f9c2538cd4
--- /dev/null
+++ b/sys-devel/byfl/Manifest
@@ -0,0 +1 @@
+DIST byfl-1.2-llvm-3.5.1.tar.gz 509555 SHA256 ab3325dcc71a6bbe4b0f7cdc75a8522cce29cf60e73e11b9791360a89c684b39 SHA512 a0f9a0656f70b172f1304de90312e5fb1fe998c9315463b86db35a2ccdbb45ded75a8776160a35223a24d0fe89a253740b1acde58ba2f1b77b9f27c71d5150fb WHIRLPOOL 6be2f6812fb33f72fc1c7a4664aadbc17f4f1872052e7a01269ab4921a744afdc5716a12cd2bd12410722397ccf00bc5994627f14932f442a5e4ea2aa806c6d3
diff --git a/sys-devel/byfl/byfl-1.2.ebuild b/sys-devel/byfl/byfl-1.2.ebuild
new file mode 100644
index 000000000000..17caf4750ec1
--- /dev/null
+++ b/sys-devel/byfl/byfl-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic
+
+if [ "${PV}" = "9999" ]; then
+ LLVM_VERSION="3.6"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git http://github.com/losalamos/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ LLVM_VERSION="3.5.1"
+ MY_P="${P}-llvm-${LLVM_VERSION}"
+ SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~amd64-linux"
+fi
+
+DESCRIPTION="Compiler-based Application Analysis"
+HOMEPAGE="https://github.com/losalamos/Byfl"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="dragonegg hdf5 static-libs sqlite"
+
+RDEPEND="dragonegg? ( >=sys-devel/dragonegg-${LLVM_VERSION} )
+ >=sys-devel/clang-${LLVM_VERSION}
+ >=sys-devel/llvm-${LLVM_VERSION}
+ sys-devel/binutils
+ dev-lang/perl:=
+ dev-perl/Switch
+ hdf5? ( sci-libs/hdf5[cxx] )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ use dragonegg || export ax_cv_file_dragonegg_so=no
+ use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
+ autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
+}
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
new file mode 100644
index 000000000000..17caf4750ec1
--- /dev/null
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic
+
+if [ "${PV}" = "9999" ]; then
+ LLVM_VERSION="3.6"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git http://github.com/losalamos/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ LLVM_VERSION="3.5.1"
+ MY_P="${P}-llvm-${LLVM_VERSION}"
+ SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~amd64-linux"
+fi
+
+DESCRIPTION="Compiler-based Application Analysis"
+HOMEPAGE="https://github.com/losalamos/Byfl"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="dragonegg hdf5 static-libs sqlite"
+
+RDEPEND="dragonegg? ( >=sys-devel/dragonegg-${LLVM_VERSION} )
+ >=sys-devel/clang-${LLVM_VERSION}
+ >=sys-devel/llvm-${LLVM_VERSION}
+ sys-devel/binutils
+ dev-lang/perl:=
+ dev-perl/Switch
+ hdf5? ( sci-libs/hdf5[cxx] )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ use dragonegg || export ax_cv_file_dragonegg_so=no
+ use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
+ autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
+}
diff --git a/sys-devel/byfl/metadata.xml b/sys-devel/byfl/metadata.xml
new file mode 100644
index 000000000000..38efabe7241d
--- /dev/null
+++ b/sys-devel/byfl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name="dragonegg">Add support for non C languages through <pkg>sys-devel/dragonegg</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">losalamos/Byfl</remote-id>
+ </upstream>
+</pkgmetadata>