summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-17 10:52:38 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-17 11:03:01 -0500
commitb28240ad2f78ec1ff5395432db4def46be7effb3 (patch)
treec2c67542d83001bbe0c9fe4bd5f7b501f7ed55bc /sys-boot
parentdev-python/caldav: Run tests needing python-recurring-ical-events (diff)
downloadgentoo-b28240ad2f78ec1ff5395432db4def46be7effb3.tar.gz
gentoo-b28240ad2f78ec1ff5395432db4def46be7effb3.tar.bz2
gentoo-b28240ad2f78ec1ff5395432db4def46be7effb3.zip
sys-boot/grub: clean up autogen.sh handling
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 3f9fdfc128e2..cc531c4c9010 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -5,13 +5,13 @@ EAPI=7
# This ebuild uses 3 special global variables:
# GRUB_BOOTSTRAP: Depend on python and invoke bootstrap (gnulib).
-# GRUB_AUTOGEN: Depend on python and invoke the autogen.sh.
+# GRUB_AUTOGEN: Depend on python and invoke autogen.sh.
# GRUB_AUTORECONF: Inherit autotools and invoke eautoreconf.
#
# When applying patches:
# If gnulib is updated, set GRUB_BOOTSTRAP=1
-# If *.def is updated, set GRUB_AUTOGEN=1
-# If gnulib, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
+# If gentpl.py or *.def is updated, set GRUB_AUTOGEN=1
+# If gnulib, gentpl.py, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
#
# If any of the above applies to a user patch, the user should set the
# corresponding variable in make.conf or the environment.
@@ -156,8 +156,6 @@ src_unpack() {
src_prepare() {
default
- sed -i -e /autoreconf/d autogen.sh || die
-
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
python_setup
else
@@ -168,7 +166,7 @@ src_prepare() {
eautopoint --force
AUTOPOINT=: AUTORECONF=: ./bootstrap || die
elif [[ -n ${GRUB_AUTOGEN} ]]; then
- ./autogen.sh || die
+ FROM_BOOTSTRAP=1 ./autogen.sh || die
fi
if [[ -n ${GRUB_AUTORECONF} ]]; then