summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-14 04:25:17 +0000
committerSam James <sam@gentoo.org>2024-11-14 04:25:49 +0000
commitf54a4af3909151e35ae36f8573f77cb75c183cf3 (patch)
tree8fcb556adbbfcfda3d536e23a965c925351be5a5 /sys-block
parentsys-apps/texinfo: add 7.1.91 (unkeyworded) (diff)
downloadgentoo-f54a4af3909151e35ae36f8573f77cb75c183cf3.tar.gz
gentoo-f54a4af3909151e35ae36f8573f77cb75c183cf3.tar.bz2
gentoo-f54a4af3909151e35ae36f8573f77cb75c183cf3.zip
sys-block/mbuffer: add 20241007
* Re-enable tests (pass fine here) * Use optfeature.eclass Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/mbuffer/Manifest1
-rw-r--r--sys-block/mbuffer/mbuffer-20241007.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-block/mbuffer/Manifest b/sys-block/mbuffer/Manifest
index b16d34f80aba..dc0e47e6651e 100644
--- a/sys-block/mbuffer/Manifest
+++ b/sys-block/mbuffer/Manifest
@@ -1,2 +1,3 @@
DIST mbuffer-20240107.tgz 151573 BLAKE2B 9fb8d1ead6424e676f6ec0dd591cdd48b53a5b1b4a980e23101ae1e52a0f2a0d07048208f8ae6c45aee66f963b7ed9720b47b16b04495bcba97489a87d8c8d8f SHA512 14773c1193ed5e4a0dfda4ef6bd6ccb0cf104f8c4ae1d22747e52e8247aeb1db64656700f9cf317b13140fb649db889831233f0b8fef0a8463d28713b5882977
DIST mbuffer-20240707.tgz 151887 BLAKE2B ae03f9a581ef37d7502d60df35ab7026987ca1e4cdd09b7bd0a2e90fa6f3b75aead9a6add7907f18c582ba40b110f24c9430a1e145772996641196de88a1470e SHA512 603877e86df666807c77e6147268d15242acbbc9787fbc9962af97367694a25d95eda1c66197975b858739ce4683e3c36cd1b442f65daae304f25056096319c6
+DIST mbuffer-20241007.tgz 152029 BLAKE2B d26c0d87abacc8826bf2e6f414fe9264da7b3196c62a9853a8ffb6b118df353977c38ea5b1bf79e71fadcae6585b90b1f21152f742c7fafee08ae4294acceb60 SHA512 cb8f9e962510030f8e1500dcd21a556b73144c445bc12ece3915df201fa5e8849c183546c7ce700e06d1c734c0fdf36e31046ac984e232b64f9b019b54e1ddd2
diff --git a/sys-block/mbuffer/mbuffer-20241007.ebuild b/sys-block/mbuffer/mbuffer-20241007.ebuild
new file mode 100644
index 000000000000..e0721f774e17
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20241007.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="debug ssl test"
+REQUIRED_USE="test? ( ssl )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? (
+ dev-libs/openssl
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+ "${FILESDIR}/${PN}-20200929-find-OBJDUMP.patch"
+ "${FILESDIR}/${PN}-20231216-autoconf-warning.patch"
+)
+
+src_prepare() {
+ default
+
+ ln -s "${DISTDIR}"/${P}.tgz test.tar # bug #258881
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable ssl md5)
+ $(use_enable debug)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+ # using same port and src_install may have problems (with /etc folder)
+ local -x MAKEOPTS=-j1
+
+ default
+}
+
+pkg_postinst() {
+ optfeature "autoloader support" app-arch/mt-st
+}