summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-16 00:23:25 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-16 00:23:25 +0100
commitdc4476fd5b5ab8a88749cf42cc4f59430d429e63 (patch)
tree8e75f9aea4b89e40df36ad4ba7ba8f6ce74a3171 /sys-auth
parentnet-libs/openmq-cclient: disable static libs (diff)
downloadgentoo-dc4476fd5b5ab8a88749cf42cc4f59430d429e63.tar.gz
gentoo-dc4476fd5b5ab8a88749cf42cc4f59430d429e63.tar.bz2
gentoo-dc4476fd5b5ab8a88749cf42cc4f59430d429e63.zip
sys-auth/ykclient: disable static libs, port to EAPI 7
Closes: https://bugs.gentoo.org/725690 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykclient/ykclient-2.15.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/sys-auth/ykclient/ykclient-2.15.ebuild b/sys-auth/ykclient/ykclient-2.15.ebuild
index cec75e52208d..e119df25b795 100644
--- a/sys-auth/ykclient/ykclient-2.15.ebuild
+++ b/sys-auth/ykclient/ykclient-2.15.ebuild
@@ -1,19 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Yubico C client library"
SRC_URI="http://opensource.yubico.com/yubico-c-client/releases/${P}.tar.gz"
HOMEPAGE="https://github.com/Yubico/yubico-c-client"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
LICENSE="BSD-2"
-IUSE="static-libs"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
-RDEPEND=">=net-misc/curl-7.21.1"
+RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# Tests require an active network connection, we don't want to run them
-RESTRICT="test"
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}