summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:19:52 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:30 -0700
commitea166433ee11e407976675471f537f19d4786b6b (patch)
tree91b422202645c3ccd8a9764399ebd3115b48d878 /sys-apps
parentsys-apps/semodule-utils: Sync live ebuild. (diff)
downloadgentoo-ea166433ee11e407976675471f537f19d4786b6b.tar.gz
gentoo-ea166433ee11e407976675471f537f19d4786b6b.tar.bz2
gentoo-ea166433ee11e407976675471f537f19d4786b6b.zip
sys-apps/secilc: Version updated to 3.2.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-3.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index bbd35265e8dd..e79539ff33ba 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1 +1,2 @@
DIST secilc-3.1.tar.gz 176631 BLAKE2B e79818580d2a788d672574ebd77349f0c59b678d2be628479f517412ca876fa225ba0dd63ef3200ed15ff693cd5f4cb4ff537d81666fef3a008ba4b3a7577e0c SHA512 79e3e4910178af49ea164d620aa997adb21dd18581c054a4023dd9116ec9dd203bd12989ef308aa1d253b47fcd251ee2b99c26e143d1db3de22a7f374ff38e0b
+DIST secilc-3.2.tar.gz 179384 BLAKE2B 89a02ceeaeb221eb5e819f6c6f09cd7e4675971d1870850867f0e258e3cf089c048a2976016c8200cffcb7904aae01d7e9d6a0c086a2a33fb08020df10b92059 SHA512 ef60aaaba3a9b4d8da496ae80203a8c9595dc2f97f767432f6b3323395fda65293540ed9574e8d7d3f40854c3ad38a95a7b96939b6c689f02a3d04834b81ca45
diff --git a/sys-apps/secilc/secilc-3.2.ebuild b/sys-apps/secilc/secilc-3.2.ebuild
new file mode 100644
index 000000000000..c7694587c83e
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+RDEPEND="${DEPEND}"
+BDEPEND="app-text/xmlto"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}