summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-24 23:08:32 +0000
committerSam James <sam@gentoo.org>2023-11-24 23:08:32 +0000
commitbf68b680c3fff24dcbebc2ea782b2b2c15048a78 (patch)
treeaf2993206cf6791b9b038eb83e13775866daab54 /sys-apps
parentdev-libs/libxml2: add 2.12.1 (diff)
downloadgentoo-bf68b680c3fff24dcbebc2ea782b2b2c15048a78.tar.gz
gentoo-bf68b680c3fff24dcbebc2ea782b2b2c15048a78.tar.bz2
gentoo-bf68b680c3fff24dcbebc2ea782b2b2c15048a78.zip
sys-apps/ethtool: add 6.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-6.6.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index dc73cb4bb28f..56342594ffb4 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -5,3 +5,4 @@ DIST ethtool-6.2.tar.xz 332708 BLAKE2B b3fa2571b1efef3b686eb4f20b33e6cc32bdb8cff
DIST ethtool-6.3.tar.xz 338764 BLAKE2B c06509525db47f8ee7c220d0b880fe80323a4a00036e9698432b1b9c85ad75045e98b23498f6283497728cafd187ca173b15f3ad60f8e6f8b4d0c5688d84a1f9 SHA512 85e5ecd20abf737e94ddc093f15ab0b876f763a886e3327027c448c0efcc091628c3df42070f30583551fa12f866f5b49d41fb3333acdf854a59bba671646320
DIST ethtool-6.4.tar.xz 340844 BLAKE2B 15fbd3f2db21b7a880d040bbd5fffc51f5335d182e1d3d23dc23d2cfd3b572fabb5914426f0e8470f4374ceddb07741ed1b57d058a57867b89c1ea2a78d13c10 SHA512 5e389564b41e9494df102f9fb703ae2d80ba38346d84ec6c89b024ec21c85eca9f58e88012290feaa88d3ce035d6f779913798b0ca177e8d0a08eff197eb6afd
DIST ethtool-6.5.tar.xz 344220 BLAKE2B 1cd79cbac563d63d81212e25df57cd5887e5284f9e4a5e73d483a3fcc1cb18dc0679d7bf53ed424f244642fc7aeda2b6cc5b11341ab28e74f5397a6bbf4130e6 SHA512 07994a20f34b1c1e72f9f855972d31d027968b53b278a5b46c5a2977be8d7152e6439c9719001101be85359876d9d932d2afb9561af9967e84d8a447a7d0c558
+DIST ethtool-6.6.tar.xz 352476 BLAKE2B dfbc5f9a6ac63210d1ae305c2458cc44d38d44fcc272c9b0397a13a93e0aa0a09e3750e330a27dcf4dce796c6bd302c4d4c1fd91faab824a81949c31f1ed3504 SHA512 1e7eae3abe59e6af4bce0ebedd0a7ea84d1b0adc7693a0f03021c4096677096a022fdae521ac02413f9db46ee232b89dd2015a116845aa6ca7686fdda50a5b21
diff --git a/sys-apps/ethtool/ethtool-6.6.ebuild b/sys-apps/ethtool/ethtool-6.6.ebuild
new file mode 100644
index 000000000000..a7eff7664c78
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}