summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leonard <antonlacon@gmail.com>2020-04-25 13:32:57 -0700
committerZac Medico <zmedico@gentoo.org>2020-05-05 16:56:43 -0700
commit6a381b421b8283c73c2bd6e5d4e4a46cbe9a43a2 (patch)
tree706e206a9181a9cf8006f7bda1e6cd03ad63c719 /sys-apps
parentapp-crypt/cfssl: stabilize 1.4.1 on amd64 (diff)
downloadgentoo-6a381b421b8283c73c2bd6e5d4e4a46cbe9a43a2.tar.gz
gentoo-6a381b421b8283c73c2bd6e5d4e4a46cbe9a43a2.tar.bz2
gentoo-6a381b421b8283c73c2bd6e5d4e4a46cbe9a43a2.zip
sys-apps/portage: add zstd USE flag
The zstd USE flag sets the default binary package compression to use zstd and adds it as a dependency. Masked on riscv until app-arch/zstd is keyworded. Closes: https://github.com/gentoo/gentoo/pull/15520 Bug: https://bugs.gentoo.org/715108 Bug: https://bugs.gentoo.org/719456 Signed-off-by: Ian Leonard <antonlacon@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index f581cb8ae977..4134cca8ce92 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr zstd"
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
>=app-arch/tar-1.27
@@ -54,6 +54,7 @@ RDEPEND="
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
) )
+ zstd? ( app-arch/zstd )
!<app-admin/logrotate-3.8.0"
PDEPEND="
!build? (
@@ -115,6 +116,12 @@ python_prepare_all() {
|| die "failed to append to make.globals"
fi
+ if use zstd ; then
+ einfo "Adding BINGPKG_COMPRESS=\"zstd\" to make.globals ..."
+ echo -e '\nBINGPKG_COMPRESS="zstd"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
if use build || ! use rsync-verify; then
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
-i cnf/repos.conf || die "sed failed"