summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-06-27 19:07:30 +0000
committerSam James <sam@gentoo.org>2023-06-27 20:53:53 +0100
commit32765ef2ededce753ce94fe8568e4254a4cacdfd (patch)
treef649d021214be4ef608d90c8f17929ffc5f4f7db /sys-apps
parentdev-python/pyzmq: Stabilize 25.1.0 hppa, #909259 (diff)
downloadgentoo-32765ef2ededce753ce94fe8568e4254a4cacdfd.tar.gz
gentoo-32765ef2ededce753ce94fe8568e4254a4cacdfd.tar.bz2
gentoo-32765ef2ededce753ce94fe8568e4254a4cacdfd.zip
sys-apps/iproute2: Add missing limits.h include to bridge/mdb.c
Fixes build on musl. Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31646 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/files/iproute2-6.4.0-add-missing-limits.h-include.patch22
-rw-r--r--sys-apps/iproute2/iproute2-6.4.0.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-6.4.0-add-missing-limits.h-include.patch b/sys-apps/iproute2/files/iproute2-6.4.0-add-missing-limits.h-include.patch
new file mode 100644
index 000000000000..63d1397d8d3b
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-6.4.0-add-missing-limits.h-include.patch
@@ -0,0 +1,22 @@
+From https://github.com/shemminger/iproute2/pull/69/commits/030013c4b9ba032869f72b766e28eaf8c8099f36 Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Tue, 27 Jun 2023 18:58:05 +0000
+Subject: [PATCH] bridge: mdb: add missing limits.h include
+
+Adding limits.h include for USHRT_MAX and ULONG_MAX. Don't rely on it
+being transitively include (as it is not on musl).
+
+Signed-off-by: Violet Purcell <vimproved@inventati.org>
+--- a/bridge/mdb.c
++++ b/bridge/mdb.c
+@@ -15,6 +15,7 @@
+ #include <string.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
++#include <limits.h>
+
+ #include "libnetlink.h"
+ #include "utils.h"
+--
+2.41.0
+
diff --git a/sys-apps/iproute2/iproute2-6.4.0.ebuild b/sys-apps/iproute2/iproute2-6.4.0.ebuild
index 5281e47ca76a..1a167417ca7d 100644
--- a/sys-apps/iproute2/iproute2-6.4.0.ebuild
+++ b/sys-apps/iproute2/iproute2-6.4.0.ebuild
@@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.1.0-mtu.patch # bug #291907
"${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
"${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
+ "${FILESDIR}"/${PN}-6.4.0-add-missing-limits.h-include.patch
)
src_prepare() {