summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /sys-apps/zram-generator
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'sys-apps/zram-generator')
-rw-r--r--sys-apps/zram-generator/zram-generator-1.1.2-r1.ebuild (renamed from sys-apps/zram-generator/zram-generator-1.1.2.ebuild)83
1 files changed, 42 insertions, 41 deletions
diff --git a/sys-apps/zram-generator/zram-generator-1.1.2.ebuild b/sys-apps/zram-generator/zram-generator-1.1.2-r1.ebuild
index e9c8dc4ca9ff..3d422cd75d43 100644
--- a/sys-apps/zram-generator/zram-generator-1.1.2.ebuild
+++ b/sys-apps/zram-generator/zram-generator-1.1.2-r1.ebuild
@@ -4,44 +4,44 @@
EAPI=8
CRATES="
- ahash-0.4.7
- anyhow-1.0.45
- autocfg-1.0.1
- bitflags-1.2.1
- cc-1.0.72
- cfg-if-1.0.0
- clap-2.33.3
- ctor-0.1.21
- dlv-list-0.2.3
- fasteval-0.2.4
- fs_extra-1.2.0
- getrandom-0.2.3
- hashbrown-0.9.1
- libc-0.2.107
- liboverdrop-0.0.2
- log-0.4.14
- memoffset-0.6.4
- nix-0.22.2
- ordered-multimap-0.3.1
- ppv-lite86-0.2.15
- proc-macro2-1.0.32
- quote-1.0.10
- rand-0.8.4
- rand_chacha-0.3.1
- rand_core-0.6.3
- rand_hc-0.3.1
- redox_syscall-0.2.10
- remove_dir_all-0.5.3
- rust-ini-0.17.0
- syn-1.0.81
- tempfile-3.2.0
- textwrap-0.11.0
- unicode-width-0.1.9
- unicode-xid-0.2.2
- wasi-0.10.2+wasi-snapshot-preview1
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0
+ ahash@0.4.7
+ anyhow@1.0.45
+ autocfg@1.0.1
+ bitflags@1.2.1
+ cc@1.0.72
+ cfg-if@1.0.0
+ clap@2.33.3
+ ctor@0.1.21
+ dlv-list@0.2.3
+ fasteval@0.2.4
+ fs_extra@1.2.0
+ getrandom@0.2.3
+ hashbrown@0.9.1
+ libc@0.2.107
+ liboverdrop@0.0.2
+ log@0.4.14
+ memoffset@0.6.4
+ nix@0.22.2
+ ordered-multimap@0.3.1
+ ppv-lite86@0.2.15
+ proc-macro2@1.0.32
+ quote@1.0.10
+ rand@0.8.4
+ rand_chacha@0.3.1
+ rand_core@0.6.3
+ rand_hc@0.3.1
+ redox_syscall@0.2.10
+ remove_dir_all@0.5.3
+ rust-ini@0.17.0
+ syn@1.0.81
+ tempfile@3.2.0
+ textwrap@0.11.0
+ unicode-width@0.1.9
+ unicode-xid@0.2.2
+ wasi@0.10.2+wasi-snapshot-preview1
+ winapi@0.3.9
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
"
inherit cargo systemd toolchain-funcs
@@ -49,16 +49,17 @@ inherit cargo systemd toolchain-funcs
DESCRIPTION="Systemd unit generator for zram swap devices"
HOMEPAGE="https://github.com/systemd/zram-generator"
SRC_URI="https://github.com/systemd/zram-generator/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ ${CARGO_CRATE_URIS}"
LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv"
IUSE="+man"
-BDEPEND="virtual/rust
+BDEPEND="
virtual/pkgconfig
- man? ( app-text/ronn-ng )"
+ man? ( app-text/ronn-ng )
+"
QA_FLAGS_IGNORED="lib/systemd/system-generators/zram-generator"